Millisecond Forums

Difference in contacting the COM port between Inquisit 3 and 4?

https://www.millisecond.com/forums/Topic15829.aspx

By Gaetan - 3/22/2015

Hi,

For a psychophysiology experiment I have to send certain codes through the com port as triggers for the psychophysiology recording program. We recently switched to Inquisit 4 on our testing computer and now we are experiencing problems when we use the code we previously used in inquisit 3 as triggers.

Previously the codes were like this:

***startvpm**

<port A>
/ numitems = 1
/ port = com1
/ subport = data
/ items = ("01000001")
/ select = sequence
/ erase = false
</port>

***start trial ******

<port B>
/ numitems= 1
/ port = com1
/ subport = data
/ items = ("01000010")
/ select = sequence
/ erase = false
</port>

***end trial ******

<port C>
/ numitems= 1
/ port = com1
/ subport = data
/ items = ("01000011")
/ select = sequence
/ erase = false
</port>

****end vpm******

<port D>
/ numitems= 1
/ port = com1
/ subport = data
/ items =< ("01000100")
/ select = sequence
/ erase = false
</port>

***start CSplus ******

<port E>
/ numitems= 1
/ port = com1
/ subport = data
/ items = ("01000101")
/ select = sequence
/ erase = false
</port>

********end CSplus ***********

<port F>
/ numitems= 1
/ port = com1
/ subport = data
/ items = ("01000110")
/ select = sequence
/ erase = false
</port>


The psychophysiology program stubbornly wants specific binary input for specific output triggers (e.g., "01000001" for A), but this mapping apparently changed somehow from Inquisit 3 to 4. Is there any place where I could find documentation to map the appropriate binary codes to the triggers in Inquisit 4? (for now we will probably stick to using Inquisit 3, but it would be nice to use the features of Inquisit 4 in combination with our psychophysiology recording program)

Thank you!

kind regards,
Gaetan
By Dave - 3/22/2015

> The psychophysiology program stubbornly wants specific binary input for specific output triggers (e.g., "01000001" for A), but this
> mapping apparently changed somehow from Inquisit 3 to 4. Is there any place where I could find documentation to map the
> appropriate binary codes to the triggers in Inquisit 4?

There hasn't been any change in that regard. The only difference is that Inquisit 4 will allow you to specify port signals as integers as an alternative to 8-bit TTL signals in binary form. The specification you have in your code (e.g., "01000001") is perfectly fine / valid Inquisit 4 syntax and should work. I suspect the problem lies elsewhere.

<port A>
/ numitems = 1
/ port = com1
/ subport = data
/ items = ("01000001")
/ select = sequence
/ erase = false
</port>

Glancing over the example <port> definitions you provided, I'd be interested to know what happens if you remove the /subport attribute, which isn't applicable to serial / COM ports anyway.
By Gaetan - 2/15/2017

If anyone still struggles with this or a similar problem, a solution that worked for me was running an inquisit 3 script before the inquisit 4 script. I think the problem was related to specifying the port setting with inquisit 4 using Windows XP as the OS still.