Millisecond Forums

Error when launching 4.0.9 Web Inquisit on Mac OS 10.5.8


https://www.millisecond.com/forums/Topic19724.aspx

By lakeside - 9/20/2016

During testing of Inquisit Web 4.0.9, we were unable to run tasks on a Mac OS 10.5.8 running Chrome 21.x, Firefox 12.x and Firefox 16.x. Purportedly, this OS is supported by Inquisit 4. Crash report from the Mac follows:

SYSTEM CONFIGURATION
Model: MacBook4,1, BootROM MB41.00C1.B00, 2 processors, Intel Core 2 Duo, 2.1 GHz, 1 GB
Graphics: kHW_IntelGMA965Item, GMA X3100, spdisplays_builtin, 144 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (5.10.91.22)
Bluetooth: Version 2.1.9f10, 2 service, 1 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HTS542512K9SA00, 111.79 GB
Parallel ATA Device: HL-DT-ST DVDRW  GSA-S10N
USB Device: Built-in iSight, (null) mA
USB Device: Apple Internal Keyboard / Trackpad, (null) mA
USB Device: IR Receiver, (null) mA
USB Device: Bluetooth USB Host Controller, (null) mA

PROBLEM DETAILS
Process:         Inquisit Web Player [716]
Path:            /Volumes/Inquisit Web Player/Inquisit Web Player.app/Contents/MacOS/Inquisit Web Player
Identifier:      com.millisecond.InquisitWebPlayer
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [76]

Interval Since Last Report:          336 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2016-09-20 10:44:41.526 -0400
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  24058177-81E2-465A-9329-783927D53F66

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Symbol not found: _OBJC_CLASS_$_NSRunningApplication
  Referenced from: /Volumes/Inquisit Web Player/Inquisit Web Player.app/Contents/MacOS/Inquisit Web Player
  Expected in: /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit

By Dave - 9/20/2016

The first few releases of Inquisit 4 still supported 10.5.8. Current releases require at least 10.6.x.

https://www.millisecond.com/products/inquisit4/requirements.aspx