Millisecond Forums

Code no longer works with Inquisit 6 / or my new computer setup

https://www.millisecond.com/forums/Topic31800.aspx

By jmwotw - 7/1/2021

Hello. I have a survey that we've used successfully for years, but either with Inquisit 6 or with my new computer setup, it doesn't work anymore. I have dual monitors of different resolutions, and when I run the program, monitor 1 shows a vertical scroll bar where it didn't use to, and I am unable to select any of the radio buttons, no matter where I click. We've specified everything in percentage terms so I don't know why the monitor resolution should matter, but there it is. Any help is appreciated. 

Thanks,
Jeff
By Dave - 7/1/2021

Jeff - 7/1/2021
Hello. I have a survey that we've used successfully for years, but either with Inquisit 6 or with my new computer setup, it doesn't work anymore. I have dual monitors of different resolutions, and when I run the program, monitor 1 shows a vertical scroll bar where it didn't use to, and I am unable to select any of the radio buttons, no matter where I click. We've specified everything in percentage terms so I don't know why the monitor resolution should matter, but there it is. Any help is appreciated. 

Thanks,
Jeff

The order of the questions matters under Inquisit 6 (consistent with how order of stimuli in /stimulustimes or -frames matters under all versions of Inquisit).

For example, here you are *first* drawing two radiobuttons elements

/ questions = [1=baby;2=car_dog; 3=babyIm;4=car_dogIm;5=questionA;6=questionB; 7=copyright_top]

and then various images (with or without captions) on top

/ questions = [1=baby;2=car_dog; 3=babyIm;4=car_dogIm;5=questionA;6=questionB; 7=copyright_top]

The images drawn "on top of" the radiobuttns can overlay and obstruct the radiobuttons, making it impossible to access them. The fix then is to reorder the questions, i.e. put the images, etc. first, and the radiobuttons last:

/ questions = [1=babyIm;2=car_dogIm;3=questionA;4=questionB; 5=copyright_top; 6=baby;7=car_dog]

Many things in the script, in particular various font sizes in /fontstyle and /responsefontstyle attributes are not specified in percentages, so these things will not scale relative to display size.
By jmwotw - 7/2/2021

Thanks, Dave. I'll try that out. 

Jeff
By Dave - 7/2/2021

Jeff - 7/2/2021
Thanks, Dave. I'll try that out. 

Jeff

Attached is a quick pass through the script with orders fixed and fonts set to percentage sizes (I'm not sure I got these right / in line with your preferences; adjust as needed).
By jmwotw - 7/3/2021

Dave - 7/2/2021
Jeff - 7/2/2021
Thanks, Dave. I'll try that out. 

Jeff

Attached is a quick pass through the script with orders fixed and fonts set to percentage sizes (I'm not sure I got these right / in line with your preferences; adjust as needed).

Worked like a charm, Dave! Thanks again.