Millisecond Forums

Used noreplacenorepeat, but stimuli still repeats across 2 blocks


https://www.millisecond.com/forums/Topic6612.aspx

By mel51 - 9/12/2011

In the first block of my program, it is meant to show randomly selected pictures from 3 lists with noreplacenorepeat - that works fine.  The problem is that the first block is practice, then we present info talking about how the next block is the real test, and then several more pictures are meant to be shown, but these pictures have to be different from the ones in the practice run.  Even though I've used noreplacenorepeat in the trials for selecting the pictures, some of the same pictures from the practice run show up.  I've also tried putting noreplacenorepeat in the picture element, but the same thing happened. 


Here are the relevant parts of the code:



<picture Sport>
/ numitems = 13
/ items = Sport
</picture>

<item Sport>
/ 1 = "Sp1.jpg"
/ 2 = "Sp2.jpg"
/ 3 = "Sp3.jpg"
/ 4 = "Sp4.jpg"
/ 5 = "Sp5.jpg"
/ 6 = "Sp6.jpg"
/ 7 = "Sp7.jpg"
/ 8 = "Sp8.jpg"
/ 9 = "Sp9.jpg"
/ 10 = "SpR1.jpg"
/ 11 = "SpR2.jpg"
/ 12 = "SpR3.jpg"
/ 13 = "SpR4.jpg"
</item>

<picture Shop> 
/ numitems = 13
/ items = Shop
</picture>

<item Shop>
/ 1 = "Sh1.jpg"
/ 2 = "Sh2.jpg"
/ 3 = "Sh3.jpg"
/ 4 = "Sh4.jpg"
/ 5 = "Sh5.jpg"
/ 6 = "Sh6.jpg"
/ 7 = "Sh7.jpg"
/ 8 = "Sh8.jpg"
/ 9 = "Sh9.jpg"
/ 10 = "ShR5.jpg"
/ 11 = "ShR6.jpg"
/ 12 = "ShR7.jpg"
/ 13 = "ShR8.jpg"
</item>

<picture Neutral> 
/ numitems = 4
/ items = neutral
</picture>

<item neutral>
/ 1 = "Ne1.jpg"
/ 2 = "Ne2.jpg"
/ 3 = "Ne3.jpg"
/ 4 = "Ne4.jpg"
</item>


<trial ShopNoF> 
/ validkeys = ("s", "g")
/ correctresponse = ("g")
/ stimulustimes = [1=noreplacenorepeat(Shop)]
</trial>

<trial SportNoF> 
/ validkeys = ("s", "g")
/ correctresponse = ("s")
/ stimulustimes = [1=noreplacenorepeat(Sport)]
</trial>

<trial NeutralNoF> 
/ validkeys = ("s", "g")
/ correctresponse = ("g")
/ stimulustimes = [1=noreplacenorepeat(Neutral)]
</trial>


<block NeutralNoFeed>
/ screencolor = (255, 255, 255)
/ preinstructions = (bw)
/ trials = [1-2=NeutralNoF ; 3=ShopNoF ; 4=ShopNoF ; 5=SportNoF ; 6=ShopNoF ; 7=SportNoF ; 8=NeutralNoF ; 9=SportNoF ; 10-11=SportNoF ; 12=SportNoF ; 13-14=ShopNoF ; 15=SportNoF ; 16=ShopNoF ; 17=SportNoF ; 18=NeutralNoF ; 19-20=ShopNoF]
</block>

<block Test>
/ screencolor = (255, 255, 255)
/ preinstructions = (tm)
/ trials = [1-2=ShopNoF ; 3=SportNoF ; 4=SportNoF ; 5=SportNoF ; 6=ShopNoF ; 7-8=SportNoF ; 9-10=ShopNoF]
</block>

By Dave - 9/12/2011

You must use the /resetinterval attribute to keep selection pools intact across blocks.

By mel51 - 10/24/2011

Thank you! That fixed it perfectly!