Problem at launch page (Mac/Safari)


Author
Message
jbfleming
jbfleming
Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)
Group: Forum Members
Posts: 46, Visits: 75
One of my study testers had the following error when trying to launch the study from the launch page. Only one person had this problem, so I'm not sure what caused it or how concerned I should be. Can anyone shed some light on it?

https://www.millisecond.com/forums/uploads/images/bcf98d12-9dbb-444c-bcc6-ce21.png
Dave
Dave
Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)
Group: Administrators
Posts: 11K, Visits: 65K
Hard to make any definitive determination without further details such as OS version #, browser version # and launch method used (depending on launch method, additional details such as JRE version may matter) and other circumstances. It looks some invalid parameter or argument was passed to the runtime. In case you are working with URL query parameters, one of them may have been omitted or otherwise invalidated accidentally (e.g. email program destroyed the link). But I'm just speculating here.

jbfleming
jbfleming
Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)
Group: Forum Members
Posts: 46, Visits: 75
I believe he was just hitting the Start button there on the screen. The link he followed to get to this screen was generated by another web page and would have included all parameters. (I have tried starting it without the parameters before and get a different error message anyway).  I do not know which versions of MacOS and Safari he was using, and I don't think I can find out.

I did have at least one other tester for whom the Start button did not work, after installing the plugin, who was also using a Mac. However, I have personally tested from MacOS and several browsers on Windows with no problems.


jbfleming
jbfleming
Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)
Group: Forum Members
Posts: 46, Visits: 75
I'm going to send him a direct link to the study and have him try again to see if I can get more details.
jbfleming
jbfleming
Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)Guru (9.7K reputation)
Group: Forum Members
Posts: 46, Visits: 75
As an update to this - the tester who had the issue, when he tried again, was able to launch the study. I think it was an error on his part the first time around, especially since it hasn't happened to anyone else. Thanks!
Dave
Dave
Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)
Group: Administrators
Posts: 11K, Visits: 65K
Thanks for the update! Mysterious, but glad to hear it's been working on 2nd try and for everyone else.

guirusso
guirusso
Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)
Group: Forum Members
Posts: 3, Visits: 37
I actually have run into the same problem.

The plugin couldn't be installed when using Safari in a Mac desktop, then it worked in the same computer's Google Chrome.
For web participants, is there any browsers suggested for participants? Does any browser seem to work better?
I ask this question as I may ask participants to use the specific browser.

Best,
Gui

Dave
Dave
Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)
Group: Administrators
Posts: 11K, Visits: 65K
Different browsers support different technologies, which is one of the reasons why multiple launch methods are made available. To make matters worse, browser vendors keep changing plugin support and handling all the time. In other words, what works in today's browser version, might suddenly not work after tomorrow's browser update. For example, recent Chrome versions have started to categorically ban NPAPI plugins (except for a few major ones), Mozilla/Firefox are on a similar (yet not quite as drastic) trajectory with plans to disable plugins by default starting with FF30. Other additional factors come into play, too, which are not directly related to the specific browser in use: E.g. an OSX user might have Gatekeeper (https://support.apple.com/kb/ht5290) set to categorically prevent any applications from running that have not been downloaded via Apple's own AppStore.

In that environment, it is not straightforward to make a general recommendation as to what browser "works best". It really depends, and what works best today may not do so tomorrow.

With that said, making use of the new Web Player launch method (available as of version 4.0.5.0) should avoid many of the issues sketched above, as it is not tied to a particular browser and the technologies it supports.

Hope this helps.

Edited 7 Years Ago by Dave
guirusso
guirusso
Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)Partner Member (526 reputation)
Group: Forum Members
Posts: 3, Visits: 37
Thanks, Dave. I think that's exactly the case
I appreciate the attention.

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search