Stimframes in surveypage after answer-check invisible


Stimframes in surveypage after answer-check invisible

Author
Message
Guido K.
Guido K.
Respected Member
Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)Respected Member (412 reputation)

Group: Forum Members
Posts: 5, Visits: 69
Dear all,
we want to program a rating-experiment: StimPic - one question - two sliders - two sliderpics as labels. Its solved with a surveypage. Problem is  "/ required=true" in sliders. If no answer is selected (sliders not moved) and NEXT-click, only the sliders and the caption (/ questions) are visible. The StimPic and the slider-label-pics (/ stimulusframes) are invisible.

What is my error in reasoning?
Thanks Guido
************************************
<item bild>
/ 1= "b1.jpg"
/ 2= "b2.jpg"
/ 3= "b3.jpg"
</item>

<picture stim>
/ items = bild
/ position = (50%, 25%)
/ size = (60%, 60%)
</picture>

<text prequest>
/ items = ("How do you feel?")
/ hjustify = left
/ fontstyle = ("Arial", 2%, true, false, false, false, 5, 255)
/ txcolor = (black)
/ txbgcolor = (white)
/ position = (50%, 55%)
</text>

<caption textar>
/ txcolor = black
/ caption="Level of internal excitation"
/ fontstyle = ("Arial", 1.5%, true, false, false, false, 5, 255)
/ position = (19%, 61%)
</caption>

<picture par>
/ items = ("SAM-A9.png")
/ halign = left
/ valign = top
/ position = (4%, 66%)
/ size = (40%, 40%)
/ erase = false
</picture>

<slider sar>
/ range = (1, 9)
/ position = (6%, 78%)
/ slidersize= (36%, 10%)
/ showtooltips = false
/ required = true
</slider>

<caption textva>
/ caption="Valence"
/ fontstyle = ("Arial", 1.5%, true, false, false, false, 5, 255)
/ position = (67%, 61%)
</caption>

<picture pva>
/ items = ("SAM-V9.png")
/ halign = left
/ valign = top
/ position = (48%, 66%)
/ size = (40%, 40%)
</picture>

<slider sva>
/ range = (1, 9)
/ position = (51%, 78%)
/ slidersize= (36%, 10%)
/ showtooltips = false
/ required=true
</slider>

<surveypage spage>
/ finishlabel = "Next"
/ stimulusframes = [1=stim;2=prequest;3=par;4=pva]
/ questions = [1=sar;2=sva;3=textar;4=textva]
</surveypage>

<block pre>
/ trials = [1-3=spage]
</block>

<expt>
/ blocks = [1=pre]
</expt>

Dave
Dave
Supreme Being
Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)

Group: Administrators
Posts: 9.2K, Visits: 39K
There is no error in your reasoning. In Inquisit 4, currently anything displayed via /stimulusframes on a <surveypage> is not re-drawn in case of a non-response and the screen updating it involves. The only immediate workaround I can think of is setting the screencolor to transparent (and back to e.g. white) as in

<surveypage spage>
/ ontrialbegin = [block.pre.screencolor=transparent]
/ ontrialend = [block.pre.screencolor=white]

/ finishlabel = "Next"
/ stimulusframes = [1=stim,prequest,par,pva]
/ questions = [1=sar;2=sva;3=textar;4=textva]
</surveypage>

which, unfortunately, may result in an (ugly) pinkish rendering artifact around the <slider> controls. Perhaps you can live with that, though, for the time being.

Hope this helps.


alexknyde
alexknyde
Associate Member
Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)Associate Member (96 reputation)

Group: Forum Members
Posts: 6, Visits: 23
Dave - Monday, August 11, 2014
There is no error in your reasoning. In Inquisit 4, currently anything displayed via /stimulusframes on a <surveypage> is not re-drawn in case of a non-response and the screen updating it involves. The only immediate workaround I can think of is setting the screencolor to transparent (and back to e.g. white) as in

<surveypage spage>
/ ontrialbegin = [block.pre.screencolor=transparent]
/ ontrialend = [block.pre.screencolor=white]

/ finishlabel = "Next"
/ stimulusframes = [1=stim,prequest,par,pva]
/ questions = [1=sar;2=sva;3=textar;4=textva]
</surveypage>

which, unfortunately, may result in an (ugly) pinkish rendering artifact around the <slider> controls. Perhaps you can live with that, though, for the time being.

Hope this helps.


Have you found a workaround to this problem that doesn't involve the pink rendering? 
Dave
Dave
Supreme Being
Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)

Group: Administrators
Posts: 9.2K, Visits: 39K
alexknyde - Friday, August 3, 2018
Dave - Monday, August 11, 2014
There is no error in your reasoning. In Inquisit 4, currently anything displayed via /stimulusframes on a <surveypage> is not re-drawn in case of a non-response and the screen updating it involves. The only immediate workaround I can think of is setting the screencolor to transparent (and back to e.g. white) as in

<surveypage spage>
/ ontrialbegin = [block.pre.screencolor=transparent]
/ ontrialend = [block.pre.screencolor=white]

/ finishlabel = "Next"
/ stimulusframes = [1=stim,prequest,par,pva]
/ questions = [1=sar;2=sva;3=textar;4=textva]
</surveypage>

which, unfortunately, may result in an (ugly) pinkish rendering artifact around the <slider> controls. Perhaps you can live with that, though, for the time being.

Hope this helps.


Have you found a workaround to this problem that doesn't involve the pink rendering? 

Depends on what exactly you want to do. The easiest way would be to use <image> and <caption> elements displayed via /questions instead of <text> and <picture> elements displayed via /stimulusframes. The two approaches can be combined if need be for data logging purposes:

https://www.millisecond.com/forums/FindPost15230.aspx

GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search