Mousecursor not showing in screencapture


Author
Message
lwise
lwise
Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)
Group: Forum Members
Posts: 10, Visits: 28
I am having problems getting the mousecursor to show in screencapture

The script shows a video and participants select a location on the video and screencapture saves this final frame.

When I developed the script on my MacBook Air it was working as I expected but trying on other laptops, the cursor didn't show. I just restarted my MacBookAir and now there is no cursor on my screenshots too.

For each trial I have set
screencapture = true
showmousecursor = true

Any tricks for settings that will get Windows and Mac printscreen to show the cursor?

(I have the mouse cursor x and y positions but it will be a tedious process to process responses this way)

Thanks
Lisa
Dave
Dave
Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)
Group: Administrators
Posts: 11K, Visits: 74K
As far as I am aware, screencaptures will never include the mouse cursor and cannot be made to include it, I'm afraid.

The only potential alternative I can think of, would be to specify the <trial>'s /draw attribute to visualize the mouse path / position. Whether you'll find that workable in your scenario, I'm not sure.

lwise
lwise
Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)
Group: Forum Members
Posts: 10, Visits: 28
thanks for the quick reply - it is so totally mystifying that by a strange set of coincidences, it worked all day capturing mouse position. I was using Camtasia and a few other image editing things so who knows what combination of things caused it to work.

I'll try the drawing thing but it probably won't be suitable.

Lisa



Dave
Dave
Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)
Group: Administrators
Posts: 11K, Visits: 74K
Very possible that Camtasia running in the background caused that effect. It hooks the display system to do its thing.

lwise
lwise
Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)
Group: Forum Members
Posts: 10, Visits: 28
Does anyone know of any issues in running Inquisit with Camtasia doing screen recording in the background? It appeared to work (as in, Camtasia recorded the screen as desired for my brief test) but are there potential issues with timing or anything else that I should worry about?

It would be a quick fix for this project, but might be useful for future projects.

Thanks
Lisa
Dave
Dave
Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)
Group: Administrators
Posts: 11K, Visits: 74K
It's probably fine provided (a) you're not running a low-end system and (b) don't do anything where stimulus-timing is particularly important (e.g. priming paradigms or the like). I don't think the question can be answered generally, effects may vary from system to system to a certain degree -- the only way to be sure is testing / measuring.

lwise
lwise
Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)
Group: Forum Members
Posts: 10, Visits: 28
Seems like most of my issues are because I was using a Macbook Air for developing this script and it seems to have some funky things going on with the screen. I am running a video in one trial, the participant selects a location at the end of the video, and then in the next trial, I present the final frame of the video as a jpg, the location of their selection from the previous trial, and get them to rate their confidence in their selection.

So in one trial, a video plays, and in the next trial, an image is shown, with some text overlaying it. This image and selected location is captured via screencapture. This actually happens perfectly well on a MacBook Pro running OSX 10.6, and on a Windows 7 laptop, but on the Macbook Air running OSX 10.9, the image from the second trial doesn't show properly unless I switch to a different window and then back to Inquisit (when the screen redraws). The screencapture image shows the unrefreshed screen if I don't swap between windows to force-draw the screen, and the correct screen if I do a swap between windows.

Are there known issues with Mavericks or Macbook Airs and Inquisit? Or do I need to consider display size and canvas size (the videos and images are currently sized to be (100%, 100%)?

Thanks in advance
Lisa



Dave
Dave
Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)
Group: Administrators
Posts: 11K, Visits: 74K
First time I've heard of any such issue. My first guess would be that this is not about 10.9 / Mavericks, but something else on that particular box (think: broken graphics card driver, some other application interfering with the display system). Does any of that ring a bell?

lwise
lwise
Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)Esteemed Member (1.7K reputation)
Group: Forum Members
Posts: 10, Visits: 28
No, no other issues that I know of. I'll test on another Macbook Air and let you know :-) 
But this is a reasonably new-to-me computer, and it isn't running too many things. The Macbook Pro on the other hand, is quite old and has a gizillion different random things on it, but the script ran straightforwardly on its own 13" LCD screen as well as on an Apple Cinema display while running lots of other things ...

Lisa
Dave
Dave
Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)Supreme Being (966K reputation)
Group: Administrators
Posts: 11K, Visits: 74K
Hmm, let me know how the test on that other Air works out. If it turns out to be reproducible, can you cut the script down to size (sufficient to show the issue -- single video / single still frame; but absent any unrelated stuff) and get that to us so we can try to reproduce / identify the cause? I don't know how large your videos are. If rather small, you can attach an archive to this thread or email it to support<at>millisecond.com. If too large, you could upload the files somewhere (Dropbox or the like) and post or email a download link. Thanks!

GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search