Unable to obtain parallel port 1


Author
Message
peterandrewbaldwin
peterandrewbaldwin
Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)
Group: Forum Members
Posts: 8, Visits: 17
Hi,

I am trying to send binary signals from one PC to another via parallel port. Each time I run the script I get the error:
"Unable to obtain the address for parallel port 1."

I have never encountered this problem and I have never had to specify a port address before.
Markers are coded as:

<port baselinestart>
/ port = LPT1
/ subport = data
/ items = "01100101"
</port>

When I change the port type to COM1 (serial) the script runs fine.

There are definitely parallel ports on both machines, and they are connected via parallel cable.

Only clues as to what might be going on?

Thanks!

Dave
Dave
Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)
Group: Administrators
Posts: 11K, Visits: 76K
Most likely the port number for the respective parallel port is not 1. You can check which it is via the system's device manager. The /port attribute in the <port> element must match that number, i.e., if the number is e.g. 3, it ought to read

<port baselinestart>
/ port = LPT3
/ subport = data
/ items = "01100101"
</port>

You can also try out different port numbers & sending / receiving signals via Tools -> Parallel Port Monitor... in Inquisit.

peterandrewbaldwin
peterandrewbaldwin
Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)Expert (1K reputation)
Group: Forum Members
Posts: 8, Visits: 17
Thanks for that. Turned out to be a faulty parallel port. So quickly I blame the software ;)
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search