White box on survey page when no response is given


White box on survey page when no response is given

Author
Message
Chemical_Music
Chemical_Music
Partner Member
Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)

Group: Forum Members
Posts: 4, Visits: 83
Hello,

I am making a survey page that asks about participants' mood, and it is virtually complete. However, there is one issue - if you hit the "finish" button without clicking one of the radio buttons, a white box appears over the stimuli, as shown below:
https://www.millisecond.com/forums/uploads/images/b2797074-d438-4010-9ae7-da60.jpg
https://www.millisecond.com/forums/uploads/images/61f64c83-4ee6-44d6-81c9-6dca.png
I've tried setting all the stimuli to erase = false, but this doesn't seem to help. Is this a problem with survey page, or maybe my implementation of the radio buttons?
I wanted to use radio buttons in particular so I could designate the data output numerically (0-4), as opposed to having the output be the name of the picture (b1-b5) the participant clicks.

Here is my code:
<defaults>
/screencolor = white
</defaults>

<Page aftermoodq>
You're doing great! Press the 'Space' bar to proceed to the next game.
</page>

<page end>
Nice! Please press the 'Space' bar to continue.
</page>

<expt MoodTest>
/blocks = [1 = MoodQ]
/postinstructions = (aftermoodq)
</expt>

<block MoodQ>
/preinstructions = (end)
/trials = [1 = MQ]
</block>

<surveypage MQ>
/stimulustimes = [0 = happylabel, nothappylabel, somewhathappy, moodquestion, MoodInstructions, scale, b1, b2, b3, b4, b5]
/questions = [1 = Mquestion]
/showpagenumbers = false
/showquestionnumbers = false
</surveypage>

<radiobuttons Mquestion>
/size = (1%, 1%)
/position = (10%, 57%)
/caption = ""
/ options = ("                 ", "                 ", "                 ", "                 ", "                 ")
/optionvalues = ("0", "1", "2", "3", "4")
/orientation = horizontal
/required = true
</radiobuttons>

<item b1>
/1 = "NotHappy.jpg"
</item>

<item b2>
/1 = "SecondNotHappy.jpg"
</item>

<item b3>
/1 = "SomewhatHappy.jpg"
</item>

<item b4>
/1 = "SecondHappiest.jpg"
</item>

<item b5>
/1 = "Happiest.jpg"
</item>

<picture b1>
/erase = false
/items = b1
/size = (12%, 12%)
/ position = (10%, 50%)
</picture>

<picture b2>
/erase = false
/items = b2
/size = (12%, 12%)
/ position = (30%, 50%)
</picture>

<picture b3>
/erase = false
/items = b3
/size = (12%, 12%)
/ position = (50%, 50%)
</picture>

<picture b4>
/erase = false
/items = b4
/size = (12%, 12%)
/ position = (70%, 50%)
</picture>

<picture b5>
/erase = false
/items = b5
/size = (12%, 12%)
/position = (90%, 50%)
</picture>

<item scale>
/1 = "scale.jpg"
</item>

<picture scale>
/erase = false
/items = scale
/size = (80%,5%)
/position = (50%,50%)
</picture>

<Text MoodQuestion>
/erase = false
/items = ("How happy are you right now?")
/position = (50%, 40%)
/size = (100%, 20%)
/ fontstyle = ("Arial", 32pt, true)
</text>

<text NotHappyLabel>
/erase = false
/items = ("Not happy at all")
/position = (10%, 70%)
/size = (20%, 20%)
</text>

<text HappyLabel>
/erase = false
/items = ("Very happy!")
/position = (90%, 70%)
/size = (20%, 20%)
</text>

<text SomewhatHappy>
/erase = false
/items = ("Somewhat happy")
/position = (50%, 70%)
/size = (20%, 20%)
</text>


<text MoodInstructions>
/items = ("Use the mouse to choose the face that best describes you!")
/erase = false
/position = (50%, 46%)
/size = (100%, 20%)
/ fontstyle = ("Arial", 16pt, true)
</text>

Thank you for your help!
Dave
Dave
Supreme Being
Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K
This a limitation in how <surveypage>s work in Inquisit 4. If responding to a question is mandatory but no response is given, the question will be re-drawn (and if there is a /caption, it will be displayed in red). However, any stimuli displayed via the <surveypage>'s /stimulustimes or -frames are *not* redrawn. This is what happens here. Unfortunately there is no good way to avoid or work around this.

You may thus want to consider alternatives. For example, you could set up a standard <trial> element that performs essentially the same function or use a <likert> element.





Chemical_Music
Chemical_Music
Partner Member
Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)Partner Member (712 reputation)

Group: Forum Members
Posts: 4, Visits: 83
I will try with a likert - thank you for your help!
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search