malfunction in adaptive n-back task script


Author
Message
IMPS
IMPS
Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)Associate Member (210 reputation)
Group: Forum Members
Posts: 1, Visits: 2
Hi. The script of the adaptive n-back task does not work properly. It is only starting the first 2 trials and then stops giving this error message: Unable to initialize <picture nontargetshape> item number 0. Verify the item exists and is correctly defined.
We did not do any changes to the script after downloading it. Therefore I assume that others might have encounterd similar problems and as I am completely unfamiliar with programming support would be highly appreciated.
Thanks for any help.

Dave
Dave
Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)Supreme Being (911K reputation)
Group: Administrators
Posts: 11K, Visits: 65K
There is a minor mistake in the script's <list notargetvalue> element that can lead to the detailed error. The fix is to change the erroneous /selectionmode specification

<list notargetvalue>
/items = (1, 2, 3, 4, 5, 6, 7, 8)
/ not = (values.currenttarget)
/ selectionmode = replace
</list>

to the proper

<list notargetvalue>
/items = (1, 2, 3, 4, 5, 6, 7, 8)
/ not = (values.currenttarget)
/ selectionmode = random
/ replace = true

</list>
PWillette
PWillette
Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)
Group: Forum Members
Posts: 2, Visits: 2
This solution also works for the following error:
n-Back was working well using using Inquisit 4, but it would present the same picture ("1.gif") over and over again.
Once I made this change, the adaptive n-Back test worked perfectly.

PWillette
PWillette
Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)Respected Member (390 reputation)
Group: Forum Members
Posts: 2, Visits: 2
I'm sorry...I meant to say the same picture repeated using Inquisit 5.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search