Including images and text in SC-IAT for Inquisit 3


Including images and text in SC-IAT for Inquisit 3

Author
Message
emily.ingalls
emily.ingalls
Respected Member
Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)

Group: Forum Members
Posts: 5, Visits: 9
Hello!
I'm in the process of trying to program an SC-IAT with text and images representing the target. My syntax for the SC-IAT with text only is working fine (thanks, in large part, to this forum), but when I include the images, I continue to get the following error: 
"/items: Unable to load the picture 'C:\Users\Emily\Desktop\Sarah IAT'. Verify that the file exists and is of a supported format."

I currently have the experiment file and the images saved in the same folder. I've also tried running it from a zipped folder, and that doesn't work. I've tried saving the pictures as both .jpg and .png. I also downloaded the standard IAT with pictures and get the same error there, so I'm not sure it's a problem with my syntax. Any suggestions on how to fix? Because I'm running in to the same error with the one I downloaded from the millisecond website, I'm thinking it might be a computer issue, but my computer works fine with the text IAT only.

Some computer details--Windows 10, 64-bit  
I'm attaching my current zipped folder for reference in case that helps. 

Thank you!!


Attachments
Sarah IAT.zip (78 views, 230.00 KB)
emily.ingalls
emily.ingalls
Respected Member
Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)

Group: Forum Members
Posts: 5, Visits: 9
Additionally, I've tried loading the contents of the zipped folder to a web script, and this also doesn't work. I get a pop up error saying the RunScriptError doesn't exist. 
Dave
Dave
Supreme Being
Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)

Group: Administrators
Posts: 8.9K, Visits: 37K
There are mistakes in your script:

<picture targetApictures>
/ items = targetApictures
/ size - (20%, 20%)
</picture>

needs to read

<picture targetApictures>
/ items = targetApictures
/ size = (20%, 20%)
</picture>

and

<trial targetAleft>
...
/stimulusframes = [1 = targetA, 2 = targetApictures]
...
</trial>

needs to read

<trial targetAleft>
/pretrialpause = values.pretrialpause
/stimulusframes = [1 = targetA, targetApictures]
...
</trial>

(same for <trial targetAright>Wink.

As for the "RunScriptError" web error message: Inquisit 3 Web will not work under Windows 10 and current browsers. You'd have to upgrade to at least Inquisit 4 Web to have support for current operating system versions and browsers.

emily.ingalls
emily.ingalls
Respected Member
Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)

Group: Forum Members
Posts: 5, Visits: 9
Thanks Dave! I will try the updated script. 

I was able to get the web version to work on Firefox as well as Internet Explorer when the images were not included, but it does not work on Chrome or Microsoft Edge. 
Dave
Dave
Supreme Being
Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)

Group: Administrators
Posts: 8.9K, Visits: 37K
Chrome has dropped all support for plugins quite a while ago -- Inquisit 3 will not work under it. For a non-plugin alternative that works under Chrome, you'd have to upgrade to Inquisit 4 Web or higher. Those versions offer an additional launch method -- the so-called "web player" -- which does not rely on plugin support.

As for Edge, here, too, lack of plugin-support is the issue. Edge was deliberately designed without plugin-support from the get-go.

Hope this clarifies.

emily.ingalls
emily.ingalls
Respected Member
Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)

Group: Forum Members
Posts: 5, Visits: 9
Yes--thanks so much!

I did get the script to run with those changes. Follow-up, however, I was hoping that the pictures would be separate from the text (so, for example, targets 1-3 are text, whereas targets 4-7 are images). With it coded as-is, the images show up on top of the text. Is there a way to include them separately? I tried numbering the picture options 4, 5, 6, and 7; changing the operator to 'or' rather than ,; and changing the operator to a semi-colon rather than a comma, but these didn't fix the issue. 

Thanks again for all your help! 
-Emily 
Dave
Dave
Supreme Being
Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)Supreme Being (415K reputation)

Group: Administrators
Posts: 8.9K, Visits: 37K
May I suggest a simple workaround to save you a lot of headaches?

Use *only* images. To have your "word" stimuli displayed, simply make an image that displays the respective word.

https://www.millisecond.com/forums/FindPost12233.aspx

I.e., have your "target" picture element have 7 items, where items 1 to 3 are images displaying your 3 target "words" and items 4  to 7 are the images you already have:

<picture targetApictures>
/ items = targetApictures
/ size = (20%, 20%)
</picture

<item targetApictures>
/ 1 = "your_1st_target_word.jpg"
/ 2 = "your_2nd_target_word.jpg"
/ 3 = "your_3rd_target_word.jpg"

/ 4 = "woman1.jpg"
/ 5 = "woman2.jpg"
/ 6 = "woman3.jpg"
/ 7 = "woman4.jpg"
</item>

Your trials, then, need only display that one <picture> element:

<trial targetAleft>
/pretrialpause = values.pretrialpause
/stimulusframes = [1 = targetApictures]
...
</trial>


Edited
2 Years Ago by Dave
emily.ingalls
emily.ingalls
Respected Member
Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)Respected Member (494 reputation)

Group: Forum Members
Posts: 5, Visits: 9
That's a good idea. Thank you! 
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search