Problems with scroll down


Problems with scroll down

Author
Message
canlabstudies
canlabstudies
Respected Member
Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)

Group: Forum Members
Posts: 15, Visits: 115
Hi!

I've been having trouble with participants being able to scroll down all the way on survey pages to click the "next" button to get to the next page. They thus are frozen on that page and have to quit. So for example, they might see a screen like this:



But be unable to scroll down any further to click the next button. This issue has come up a number of different times on different survey pages. I'll post the script for the survey page above:
<parameters>
/demographicpageinstructions = "Please select the answers that apply best. Remember that you are free to skip questions you would rather not answer.
"
</parameters>

<radiobuttons Education>
/caption = "Please indicate your highest level of education:"
/ options = ("Less than high school", "High school graduation or some university", "University graduation","Masters degree", "Doctoral or Professional Degree","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
/ size = (90%,10%)
</radiobuttons>

<dropdown PersonalIncome>
/caption = "Please indicate your current yearly income:"
/options = (
"Less than $15,000",
"$15,001 to $25,000",
"$25,001 to $35,000",
"$35,001 to $50,000",
"$50,001 to $75,000",
"$75,001 to $100,000",
"$100,001 to $150,000",
"Over $150,000","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6","7","8","9")
/required=true
/ size = (90%,10%)
</dropdown>

<radiobuttons PoliOrient1>
/caption = "Please rate your political orientation on the following scale:"
/ options = ( "Not conservative at all","Slighly conservative","Moderately conservative","Very conservative", "Extremely conservative","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
/ size = (90%,10%)
</radiobuttons>

<radiobuttons PoliOrient2>
/caption = "Please rate your political orientation on the following scale:"
/ options = ( "Not liberal at all","Slighly liberal","Moderately liberal","Very liberal", "Extremely liberal","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
/ size = (90%,10%)
</radiobuttons>

<surveypage Demographics1>
/caption ="<%parameters.demographicpageinstructions%>"
/ txcolor = black
/questions = [1 = Education, PersonalIncome, PoliOrient1, PoliOrient2]
/showpagenumbers = false
/showquestionnumbers = false
/ showbackbutton = false
</surveypage>

<survey DemoArch>
/pages = [1 = FeltUndArch1; 2=FeltUndArch2; 3=FeltUndArch3; 4 = FeltUndArch4; 5=FeltUndArch5; 6=FeltUndArch6; 7= Demographics1; 8 = Demographics2; 9=Demographics3; 10 = Demographics4; 11=Demographics5; 12=Demographics6; 13=Demographics7; 14=Demographics8]
</survey>


Any idea what might be causing it/how to fix?

Thanks!



Dave
Dave
Supreme Being
Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)

Group: Administrators
Posts: 9K, Visits: 38K
canlabstudies - Wednesday, November 15, 2017
Hi!

I've been having trouble with participants being able to scroll down all the way on survey pages to click the "next" button to get to the next page. They thus are frozen on that page and have to quit. So for example, they might see a screen like this:



But be unable to scroll down any further to click the next button. This issue has come up a number of different times on different survey pages. I'll post the script for the survey page above:
<parameters>
/demographicpageinstructions = "Please select the answers that apply best. Remember that you are free to skip questions you would rather not answer.
"
</parameters>

<radiobuttons Education>
/caption = "Please indicate your highest level of education:"
/ options = ("Less than high school", "High school graduation or some university", "University graduation","Masters degree", "Doctoral or Professional Degree","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
/ size = (90%,10%)
</radiobuttons>

<dropdown PersonalIncome>
/caption = "Please indicate your current yearly income:"
/options = (
"Less than $15,000",
"$15,001 to $25,000",
"$25,001 to $35,000",
"$35,001 to $50,000",
"$50,001 to $75,000",
"$75,001 to $100,000",
"$100,001 to $150,000",
"Over $150,000","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6","7","8","9")
/required=true
/ size = (90%,10%)
</dropdown>

<radiobuttons PoliOrient1>
/caption = "Please rate your political orientation on the following scale:"
/ options = ( "Not conservative at all","Slighly conservative","Moderately conservative","Very conservative", "Extremely conservative","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
/ size = (90%,10%)
</radiobuttons>

<radiobuttons PoliOrient2>
/caption = "Please rate your political orientation on the following scale:"
/ options = ( "Not liberal at all","Slighly liberal","Moderately liberal","Very liberal", "Extremely liberal","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
/ size = (90%,10%)
</radiobuttons>

<surveypage Demographics1>
/caption ="<%parameters.demographicpageinstructions%>"
/ txcolor = black
/questions = [1 = Education, PersonalIncome, PoliOrient1, PoliOrient2]
/showpagenumbers = false
/showquestionnumbers = false
/ showbackbutton = false
</surveypage>

<survey DemoArch>
/pages = [1 = FeltUndArch1; 2=FeltUndArch2; 3=FeltUndArch3; 4 = FeltUndArch4; 5=FeltUndArch5; 6=FeltUndArch6; 7= Demographics1; 8 = Demographics2; 9=Demographics3; 10 = Demographics4; 11=Demographics5; 12=Demographics6; 13=Demographics7; 14=Demographics8]
</survey>


Any idea what might be causing it/how to fix?

Thanks!



I think the easiest fix would be to explicitly define the /nextbuttonposition:

<parameters>
/demographicpageinstructions = "Please select the answers that apply best. Remember that you are free to skip questions you would rather not answer.
"
</parameters>

<radiobuttons Education>
/caption = "Please indicate your highest level of education:"
/ options = ("Less than high school", "High school graduation or some university", "University graduation","Masters degree", "Doctoral or Professional Degree","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
</radiobuttons>

<dropdown PersonalIncome>
/caption = "Please indicate your current yearly income:"
/options = (
"Less than $15,000",
"$15,001 to $25,000",
"$25,001 to $35,000",
"$35,001 to $50,000",
"$50,001 to $75,000",
"$75,001 to $100,000",
"$100,001 to $150,000",
"Over $150,000","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6","7","8","9")
/required=true
</dropdown>

<radiobuttons PoliOrient1>
/caption = "Please rate your political orientation on the following scale:"
/ options = ( "Not conservative at all","Slighly conservative","Moderately conservative","Very conservative", "Extremely conservative","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
</radiobuttons>

<radiobuttons PoliOrient2>
/caption = "Please rate your political orientation on the following scale:"
/ options = ( "Not liberal at all","Slighly liberal","Moderately liberal","Very liberal", "Extremely liberal","I prefer not to answer this question")
/ optionvalues = ("1","2","3","4","5","6")
/required=true
</radiobuttons>

<surveypage Demographics1>
/caption ="<%parameters.demographicpageinstructions%>"
/ txcolor = black
/questions = [1 = Education; 2=PersonalIncome; 3=PoliOrient1; 4=PoliOrient2]
/showpagenumbers = false
/showquestionnumbers = false
/ showbackbutton = false
/ nextbuttonposition = (90%,130%)
</surveypage>

<survey DemoArch>
/pages = [1 = Demographics1]
</survey>

That should ensure scrolling all the way to the bottom/button is possible.

canlabstudies
canlabstudies
Respected Member
Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)

Group: Forum Members
Posts: 15, Visits: 115
Thanks for the quick response!

So I made the suggested change (adding /nextbuttonposition = (90%,130%) to the survey page), but it doesn't appear to have fixed the issue. Instead i see the following, with no way to scroll down to click the next button or complete the last question lower down on the page:
Inline image 1
Other permutations (e.g. /nextbuttonposition = (90%, 90%) allow me to see the continue button, but not scroll down to complete the last question. 

I could just split it up so that there is only 2 questions/page so that no one needs to scroll down to complete the survey, but it would be nice if there was a way to fix it so that it could scroll.


Dave
Dave
Supreme Being
Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)

Group: Administrators
Posts: 9K, Visits: 38K
canlabstudies - Wednesday, November 15, 2017
Thanks for the quick response!

So I made the suggested change (adding /nextbuttonposition = (90%,130%) to the survey page), but it doesn't appear to have fixed the issue. Instead i see the following, with no way to scroll down to click the next button or complete the last question lower down on the page:
Inline image 1
Other permutations (e.g. /nextbuttonposition = (90%, 90%) allow me to see the continue button, but not scroll down to complete the last question. 

I could just split it up so that there is only 2 questions/page so that no one needs to scroll down to complete the survey, but it would be nice if there was a way to fix it so that it could scroll.


Hmm, the 130% for the vertical position were a guesstimate on my part. If the final (fourth) question extends vertically beyond that point, choosing a higher value (140% or 150%) such that the button ends up _below_ the question should fix it. Or am I misunderstanding your description ("... no way to scroll down to click the next button or complete the last question lower down on the page.")

To illustrate, here's how things should look / work with the next button placed below the 4th question:



Thanks!

canlabstudies
canlabstudies
Respected Member
Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)

Group: Forum Members
Posts: 15, Visits: 115
Nope, I believe you're understanding correctly!

I've tried a variety of values for the placement on the y axis (ranging from 90% to 500%, which should definitely be more than i need given that there is only one question remaining unseen on the survey page). If the value is below 100% then you can see it towards on the initial screen with scrolling, as expected. However, if the value is more than 100% I can neither see the button (since it is further down on the page), nor scroll down further to reach that button (no scroll bar appears), as shown in my previous image:

Inline image 1 

Interestingly, some of participants taking the study online do see a scroll bar, but the scroll bar will only scroll down slightly or not at all, as shown in the first image:

https://www.millisecond.com/forums/Uploads/Images/494691bc-86ca-4df6-b55f-d329.pngPost Reply

I don't know why, but adding the suggested code "/nextbuttonposition = (90%, 90-500%)" doesn't appear to affect whether or not the scroll bar appears. 


Dave
Dave
Supreme Being
Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)

Group: Administrators
Posts: 9K, Visits: 38K
canlabstudies - Thursday, November 16, 2017
Nope, I believe you're understanding correctly!

I've tried a variety of values for the placement on the y axis (ranging from 90% to 500%, which should definitely be more than i need given that there is only one question remaining unseen on the survey page). If the value is below 100% then you can see it towards on the initial screen with scrolling, as expected. However, if the value is more than 100% I can neither see the button (since it is further down on the page), nor scroll down further to reach that button (no scroll bar appears), as shown in my previous image:

Inline image 1 

Interestingly, some of participants taking the study online do see a scroll bar, but the scroll bar will only scroll down slightly or not at all, as shown in the first image:

https://www.millisecond.com/forums/Uploads/Images/494691bc-86ca-4df6-b55f-d329.pngPost Reply

I don't know why, but adding the suggested code "/nextbuttonposition = (90%, 90-500%)" doesn't appear to affect whether or not the scroll bar appears. 


Thanks for the clarification! Huh, that is very strange indeed. Would it be possible for you to post the link to the online study here (or send it to me in a private message if you don't want it public)? Maybe taking a look at that will give me some idea as to why you / some of the participants are seeing a different results than I do. Thanks!

canlabstudies
canlabstudies
Respected Member
Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)

Group: Forum Members
Posts: 15, Visits: 115
Great, thanks! Just sent you a PM.
hfarmer
hfarmer
Associate Member
Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)

Group: Forum Members
Posts: 6, Visits: 11
Hi,

I am having the same issue and was wondering if this was ever resolved.

Best,

Harry
Dave
Dave
Supreme Being
Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)Supreme Being (468K reputation)

Group: Administrators
Posts: 9K, Visits: 38K
hfarmer - Tuesday, May 29, 2018
Hi,

I am having the same issue and was wondering if this was ever resolved.

Best,

Harry

Can you attach the script, tell me which page or pages you're having the problem with and perhaps provide a screenshot so I get a sense of where exactly things cut off for you? Also, are you using the latest Inquisit version or some previous one (if the latter, please update to the latest version first). Thanks!

hfarmer
hfarmer
Associate Member
Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)Associate Member (92 reputation)

Group: Forum Members
Posts: 6, Visits: 11
Hi Dave,

Attached is the script the issue is present on the ames surveypage (page 5) in the current setup. I should say that the problem may not be identical, In my case I can set the buttons to be roughly inline with the last question (in this case around 160% on the vertical) but but if I set it any lower (e.g. 180%) then the buttons don't show up at all and at 175% I can only just see the top of the last button suggesting the scroll bar doesn't expand to let me move down and see the button (see attached image). In addition if I keep the button positions at the horizontal location I would like (20% for back and 70% for forward) then the back button doesn't show up and seems to be covered by the last question. I have resolved this in the script by moving both buttons to the right (70% and 90% respectively) which seems to be a work around but is still a bit ugly so if there is a way to get the buttons positioned below the last question that would be really useful.

Best,

Harry



GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search