parallel port address


parallel port address

Author
Message
avtobin
avtobin
Associate Member
Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)

Group: Forum Members
Posts: 6, Visits: 13
Hello all,
I am moving my inquisit experiment from one EEG system to another (previously neuroscan, now using biosemi).
I have cut/pasted the code that I have used previously to send an EEG signal from the presentation to the recording computer below. I need to change the parallel port address to &HD040 . However an error has presented to say that the parallel port address &HD040 is not a valid setting. Any advice with this would be appreciated.

<port EEGsignal>
/ port = lpt3
/ subport = data
/ items = ("00000001", "00000011", "00000101")
/ select = values.N
</port>

<port EEGsignal2>
/ port = lpt3
/ subport = data
/ items = ("00000010", "00000100", "00000110")
/select = values.N
</port>

<port EEGsignaloff>
/ port = lpt3
/ subport = data
/ items = ("00000000")
</port>



Dave
Dave
Supreme Being
Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)Supreme Being (416K reputation)

Group: Administrators
Posts: 8.9K, Visits: 37K
avtobin - Tuesday, March 6, 2018
Hello all,
I am moving my inquisit experiment from one EEG system to another (previously neuroscan, now using biosemi).
I have cut/pasted the code that I have used previously to send an EEG signal from the presentation to the recording computer below. I need to change the parallel port address to &HD040 . However an error has presented to say that the parallel port address &HD040 is not a valid setting. Any advice with this would be appreciated.

<port EEGsignal>
/ port = lpt3
/ subport = data
/ items = ("00000001", "00000011", "00000101")
/ select = values.N
</port>

<port EEGsignal2>
/ port = lpt3
/ subport = data
/ items = ("00000010", "00000100", "00000110")
/select = values.N
</port>

<port EEGsignaloff>
/ port = lpt3
/ subport = data
/ items = ("00000000")
</port>



You should be able to specify a non-standard address via the <defaults> element's /lptaddresses attribute in your script:

https://www.millisecond.com/support/docs/v4/html/language/attributes/lptaddresses.htm

I.e.

<defaults>
...
/ lptaddresses = (lpt3=D040)
...
</defaults>

Make sure that the base address is indeed correct by double-checking it via the system's device manager. Also make sure that the port you're using is indeed LPT3, otherwise adjust the port number in the above accordingly.

avtobin
avtobin
Associate Member
Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)Associate Member (262 reputation)

Group: Forum Members
Posts: 6, Visits: 13
Dave - Wednesday, March 7, 2018
avtobin - Tuesday, March 6, 2018
Hello all,
I am moving my inquisit experiment from one EEG system to another (previously neuroscan, now using biosemi).
I have cut/pasted the code that I have used previously to send an EEG signal from the presentation to the recording computer below. I need to change the parallel port address to &HD040 . However an error has presented to say that the parallel port address &HD040 is not a valid setting. Any advice with this would be appreciated.

<port EEGsignal>
/ port = lpt3
/ subport = data
/ items = ("00000001", "00000011", "00000101")
/ select = values.N
</port>

<port EEGsignal2>
/ port = lpt3
/ subport = data
/ items = ("00000010", "00000100", "00000110")
/select = values.N
</port>

<port EEGsignaloff>
/ port = lpt3
/ subport = data
/ items = ("00000000")
</port>



You should be able to specify a non-standard address via the <defaults> element's /lptaddresses attribute in your script:

https://www.millisecond.com/support/docs/v4/html/language/attributes/lptaddresses.htm

I.e.

<defaults>
...
/ lptaddresses = (lpt3=D040)
...
</defaults>

Make sure that the base address is indeed correct by double-checking it via the system's device manager. Also make sure that the port you're using is indeed LPT3, otherwise adjust the port number in the above accordingly.

Hello,

Thank you Dave I will try this in my script today and update the thread if/when successful. Much appreciated!
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search