Possibility of running Version 5 Script on Inquisit Version 4


Possibility of running Version 5 Script on Inquisit Version 4

Author
Message
trina
trina
New Member
New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)

Group: Forum Members
Posts: 5, Visits: 20
Hey, 

I have a study i want to run using the digit symbol substitution task. However, the script from the Millisecond website is version 5 which does not allow me to run it with the school who has the license for Inquisit Version 4. 

Is there any way to change the script such that i can run it on Inquisit web player 4 (without upgrading it to version 5)? 

Can anyone help me out? 

Trina 
Dave
Dave
Supreme Being
Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)

Group: Administrators
Posts: 8.8K, Visits: 36K
trina - Thursday, March 22, 2018
Hey, 

I have a study i want to run using the digit symbol substitution task. However, the script from the Millisecond website is version 5 which does not allow me to run it with the school who has the license for Inquisit Version 4. 

Is there any way to change the script such that i can run it on Inquisit web player 4 (without upgrading it to version 5)? 

Can anyone help me out? 

Trina 

> Is there any way to change the script such that i can run it on Inquisit web player 4

Yes. What you'd have to do is
- Download the Inquisit 5 version of the script,
- Open it in Inquisit Lab 4, and then
- Work through the code, i.e. replace all Inquisit 5-specific syntax features with Inquisit 4-syntax compatible equivalents (as far as any exist).

For example, Inquisit 4 syntax has no <parameters> element, so you'd have to replace that with <values>.

Give this a go and if you get stuck and don't know how to make a certain part compatible with Inquisit 4, post to this thread and I'll try to point you in the right direction.

Dave
Dave
Supreme Being
Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)

Group: Administrators
Posts: 8.8K, Visits: 36K
Dave - Thursday, March 22, 2018
trina - Thursday, March 22, 2018
Hey, 

I have a study i want to run using the digit symbol substitution task. However, the script from the Millisecond website is version 5 which does not allow me to run it with the school who has the license for Inquisit Version 4. 

Is there any way to change the script such that i can run it on Inquisit web player 4 (without upgrading it to version 5)? 

Can anyone help me out? 

Trina 

> Is there any way to change the script such that i can run it on Inquisit web player 4

Yes. What you'd have to do is
- Download the Inquisit 5 version of the script,
- Open it in Inquisit Lab 4, and then
- Work through the code, i.e. replace all Inquisit 5-specific syntax features with Inquisit 4-syntax compatible equivalents (as far as any exist).

For example, Inquisit 4 syntax has no <parameters> element, so you'd have to replace that with <values>.

Give this a go and if you get stuck and don't know how to make a certain part compatible with Inquisit 4, post to this thread and I'll try to point you in the right direction.

I made a quick pass through the keyboard input version of the Digit Symbol Substitution Task, and the revision attached below should work under Inquisit 4. If you compare the attached script to the original, that should give you a good idea of what needs to be changed in case you want to modify any of the other versions (e.g. mouse input).

Attachments
digitsymbolsubstitutiontask.iqx (9 views, 218.00 KB)
trina
trina
New Member
New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)

Group: Forum Members
Posts: 5, Visits: 20
Hi Dave,

Sorry for the late reply. I can't seem to be able to open the script you sent me, always resulting in error loading the symbol images from my folders. Is there anything I can do to change that?

Thanks again.
Trina
Dave
Dave
Supreme Being
Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)Supreme Being (374K reputation)

Group: Administrators
Posts: 8.8K, Visits: 36K
trina - Monday, March 26, 2018
Hi Dave,

Sorry for the late reply. I can't seem to be able to open the script you sent me, always resulting in error loading the symbol images from my folders. Is there anything I can do to change that?

Thanks again.
Trina

If you simply replace the original (Inquisit 5 compatible) script with the one attached above, i.e. put it in the same folder where the original script and images reside, things should work without any problem. I did just that and can confirm that the script works fine under Inquisit 4.

trina
trina
New Member
New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)New Member (36 reputation)

Group: Forum Members
Posts: 5, Visits: 20
Dave - Monday, March 26, 2018
trina - Monday, March 26, 2018
Hi Dave,

Sorry for the late reply. I can't seem to be able to open the script you sent me, always resulting in error loading the symbol images from my folders. Is there anything I can do to change that?

Thanks again.
Trina

If you simply replace the original (Inquisit 5 compatible) script with the one attached above, i.e. put it in the same folder where the original script and images reside, things should work without any problem. I did just that and can confirm that the script works fine under Inquisit 4.

Okay thank you very much! Much appreciated! 
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search