Textbox caption does not disappear


Textbox caption does not disappear

Author
Message
psych101
psych101
Associate Member
Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)Associate Member (68 reputation)

Group: Forum Members
Posts: 2, Visits: 8
Hello,
I am trying to ask some questions in a surveypage, and then present a trial with instructions. However, the caption for the last survey question remains on the screen in the background even during the later instruction trials.
(This happens if the last question is a textbox, but not radiobuttons. It seems to disappear if I include another surveypage after it also.)

Here is a simple example that recreates the problem. Any help on how to fix this would be appreciated! Thanks!


<textbox q1>
/ caption = "Question 1 caption."
</textbox>

<textbox q2>
/ caption = "Question 2 caption."
</textbox>

<surveypage demographics>
/ caption = "Please answer the following questions."
/ fontstyle = ("Verdana", -16, true, false, false, false, 5, 0)
/ questions = [1=q1;2=q2]
</surveypage>

<text instructions>
/ items = ("some text")
/ size = (20%, 20%)
</text>

<trial instructions>
/ stimulusframes = [1=instructions]
/ validresponse = (anyresponse)
</trial>

<block intro>
/ trials = [1= surveypage.demographics; 2=instructions]
</block>

<expt>
/ blocks = [1 = intro;]
</expt>


Dave
Dave
Supreme Being
Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)Supreme Being (469K reputation)

Group: Administrators
Posts: 9K, Visits: 38K
psych101 - Thursday, April 26, 2018
Hello,
I am trying to ask some questions in a surveypage, and then present a trial with instructions. However, the caption for the last survey question remains on the screen in the background even during the later instruction trials.
(This happens if the last question is a textbox, but not radiobuttons. It seems to disappear if I include another surveypage after it also.)

Here is a simple example that recreates the problem. Any help on how to fix this would be appreciated! Thanks!


<textbox q1>
/ caption = "Question 1 caption."
</textbox>

<textbox q2>
/ caption = "Question 2 caption."
</textbox>

<surveypage demographics>
/ caption = "Please answer the following questions."
/ fontstyle = ("Verdana", -16, true, false, false, false, 5, 0)
/ questions = [1=q1;2=q2]
</surveypage>

<text instructions>
/ items = ("some text")
/ size = (20%, 20%)
</text>

<trial instructions>
/ stimulusframes = [1=instructions]
/ validresponse = (anyresponse)
</trial>

<block intro>
/ trials = [1= surveypage.demographics; 2=instructions]
</block>

<expt>
/ blocks = [1 = intro;]
</expt>


Very weird, I can't seem to reproduce this, though. Two things to test:

#1: Does the problem persist if you do a clearscreen in the <trial>, i.e.:

<textbox q1>
/ caption = "Question 1 caption."
</textbox>

<textbox q2>
/ caption = "Question 2 caption."
</textbox>

<surveypage demographics>
/ caption = "Please answer the following questions."
/ fontstyle = ("Verdana", -16, true, false, false, false, 5, 0)
/ questions = [1=q1;2=q2]
</surveypage>

<text instructions>
/ items = ("some text")
/ size = (20%, 20%)
</text>

<trial instructions>
/ stimulusframes = [1=clearscreen,instructions]
/ validresponse = (anyresponse)
</trial>

<block intro>
/ trials = [1= surveypage.demographics; 2=instructions]
</block>

<expt>
/ blocks = [1 = intro;]
</expt>

#2: What happens if some other element, e.g. a non-visible <caption> is included after the 2nd <textbox>?

<textbox q1>
/ caption = "Question 1 caption."
</textbox>

<textbox q2>
/ caption = "Question 2 caption."
</textbox>

<caption c1>
/ caption = "                     "
</caption>

<surveypage demographics>
/ caption = "Please answer the following questions."
/ fontstyle = ("Verdana", -16, true, false, false, false, 5, 0)
/ questions = [1=q1;2=q2;3=c1;]
</surveypage>

<text instructions>
/ items = ("some text")
/ size = (20%, 20%)
</text>

<trial instructions>
/ stimulusframes = [1=instructions]
/ validresponse = (anyresponse)
</trial>

<block intro>
/ trials = [1= surveypage.demographics; 2=instructions]
</block>

<expt>
/ blocks = [1 = intro;]
</expt>

Thanks!

canlabstudies
canlabstudies
Respected Member
Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)Respected Member (376 reputation)

Group: Forum Members
Posts: 15, Visits: 115
Hi (me again from original post),

It seems like the issue only occurs on Mac, not windows.

The clear screen seems to solve it.

Thanks!
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search