Connect Inquisit with Sona


Connect Inquisit with Sona

Author
Message
EimS
EimS
Respected Member
Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)

Group: Forum Members
Posts: 10, Visits: 53
Hello,

I have an Inquisit webscript (https://mili2nd.co/yclb) that I'm trying to get to run from Sona (where participants sign up to a study) and once complete, the study should redirect back to Sona at the end to give students credits. As far as I can see both are set up correctly but I get error messages when I run it. It links to Inquisit fine but at the end of the study I get an error message when it is supposed to go back to Sona. The error message says 'Server Error - 404 file or directory not found'. 
Is there a way that you could check that everything looks OK from the Inquisit side and then I'll know it is a Sona issue? 

Thank you,
Eimear



Dave
Dave
Supreme Being
Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)Supreme Being (608K reputation)

Group: Administrators
Posts: 9.5K, Visits: 42K
EimS - Wednesday, December 12, 2018
Hello,

I have an Inquisit webscript (https://mili2nd.co/yclb) that I'm trying to get to run from Sona (where participants sign up to a study) and once complete, the study should redirect back to Sona at the end to give students credits. As far as I can see both are set up correctly but I get error messages when I run it. It links to Inquisit fine but at the end of the study I get an error message when it is supposed to go back to Sona. The error message says 'Server Error - 404 file or directory not found'. 
Is there a way that you could check that everything looks OK from the Inquisit side and then I'll know it is a Sona issue? 

Thank you,
Eimear



I assume you followed the instructions on the SONA help page to set this up (cf. https://www.sona-systems.com/help/inquisit.aspx ). While not wrong per se, the setup recommended there is more complicated and fragile than it needs to be. The best way to set this up is:

- Give https://mili2nd.co/yclb?survey_code=%SURVEY_CODE% as the link to your Inquisit experiment in SONA.
- Then, in your Inquisit Web experiment's settings, indicate survey_code as the name of the URL parameter Inquisit should obtain the subject ID from.
- Finally, enter only https://strath-psych.sona-systems.com/webstudy_credit.aspx?experiment_id=148&credit_token=f6290cb286034a63bc7cfc88e4c752de as the URL to redirect to in your Inquisit Web experiment's settings, the survey_code parameter will be appended automatically when Inquisit redirects to SONA for crediting.


Edited
5 Months Ago by Dave
EimS
EimS
Respected Member
Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)Respected Member (490 reputation)

Group: Forum Members
Posts: 10, Visits: 53
Dave - Wednesday, December 12, 2018
EimS - Wednesday, December 12, 2018
Hello,

I have an Inquisit webscript (https://mili2nd.co/yclb) that I'm trying to get to run from Sona (where participants sign up to a study) and once complete, the study should redirect back to Sona at the end to give students credits. As far as I can see both are set up correctly but I get error messages when I run it. It links to Inquisit fine but at the end of the study I get an error message when it is supposed to go back to Sona. The error message says 'Server Error - 404 file or directory not found'. 
Is there a way that you could check that everything looks OK from the Inquisit side and then I'll know it is a Sona issue? 

Thank you,
Eimear



I assume you followed the instructions on the SONA help page to set this up (cf. https://www.sona-systems.com/help/inquisit.aspx ). While not wrong per se, the setup recommended there is more complicated and fragile than it needs to be. The best way to set this up is:

- Give https://mili2nd.co/yclb?survey_code=%SURVEY_CODE% as the link to your Inquisit experiment in SONA, where abcd is the short code for your experiment.
- Then, in your Inquisit Web experiment's settings, indicate survey_code as the name of the URL parameter Inquisit should obtain the subject ID from.
- Finally, enter only https://strath-psych.sona-systems.com/webstudy_credit.aspx?experiment_id=148&credit_token=f6290cb286034a63bc7cfc88e4c752de as the URL to redirect to in your Inquisit Web experiment's settings, the survey_code parameter will be appended automatically when Inquisit redirects to SONA for crediting.


Thanks for that Dave - Yes, I had initially been following the other guidelines on the SONA help page but everything seems to be working now with the ones you sent. 
Best wishes,
Eimear
 
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search