My script displays twice an image, i can't delete it!


My script displays twice an image, i can't delete it!

Author
Message
Nicobu
Nicobu
Associate Member
Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)

Group: Forum Members
Posts: 5, Visits: 19
Hi, I've created this script to do the SAMP task on Inquisit because i'm running an AMP and other surveys with this script,. I did it on my laptop and it appeared to be ok, but when I moved to the lab (where I'm going to save the data) it displays another one and half of the picture its in HUGE size and I don't know how to "delete" the second image from the script.
Can you help me with that, please? 
I'll appreciate it!!


Here's my script, the first and second images are screenshots of the computer's lab with the problem


Notes: I move pixel by pixel (of the percent in the screen) the sliders, images and texts
Attachments
SAMP.iqx (6 views, 8.00 KB)
Screenshot 2.png (6 views, 674.00 KB)
Screenshot 3.png (6 views, 702.00 KB)
Dave
Dave
Supreme Being
Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)Supreme Being (749K reputation)

Group: Administrators
Posts: 9.9K, Visits: 49K
Nicobu - 11/6/2019
Hi, I've created this script to do the SAMP task on Inquisit because i'm running an AMP and other surveys with this script,. I did it on my laptop and it appeared to be ok, but when I moved to the lab (where I'm going to save the data) it displays another one and half of the picture its in HUGE size and I don't know how to "delete" the second image from the script.
Can you help me with that, please? 
I'll appreciate it!!


Here's my script, the first and second images are screenshots of the computer's lab with the problem


Notes: I move pixel by pixel (of the percent in the screen) the sliders, images and texts

You're displaying two versions of the image. First you have the <picture> elements:

<picture adnv>
/ items = advnueva
/ position = (50, 31)
/ size = (60%, 40%)
</picture>

<picture adact>
/ items = advactual
/ position = (50, 31)
/ size = (60%, 40%)
</picture>

<picture adantg>
/ items = advantigua
/ position = (50, 31)
/ size = (60%, 40%)
</picture>

and then the <image> elements:

<image nvs>
/ items = ("<%picture.adnv.currentitem%>")
/ position = (50,31)
</image>

<image acts>
/ items = ("<%picture.adact.currentitem%>")
/ position = (50,31)
</image>

<image antgs>
/ items = ("<%picture.adantg.currentitem%>")
/ position = (50,31)
</image>

Your surveypages display both:

<surveypage RANEF_Nuevas>
/ stimulusframes = [1=adnv]
/ fontstyle = ("Arial", -24, false, true)
/ questions = [1=nvs; 2=slid_rea01; 3=slid_rea02; 4=slid_rea03; 5=slid_fam; 6= descripcionTxtRanef]
/ showpagenumbers = false
/ showquestionnumbers = false
/ finishlabel = "Continuar"
/ nextbuttonposition = (80%, 90%)
</surveypage>

What you should do is:
(1) Move the <picture> elements to off-screen positions:

<picture adnv>
/ items = advnueva
/ position = (-10%, -10%)
/ size = (0%, 0%)
</picture>

<picture adact>
/ items = advactual
/ position = (-10%, -10%)
/ size = (0%, 0%)
</picture>

<picture adantg>
/ items = advantigua
/ position = (-10%, -10%)
/ size = (0%, 0%)
</picture>

(2) Size and position the <image> elements properly:

<image nvs>
/ items = ("<%picture.adnv.currentitem%>")
/ position = (20%,11%)
/ imagesize = (60%, 40%)
</image>

<image acts>
/ items = ("<%picture.adact.currentitem%>")
/ position = (20%,11%)
/ imagesize = (60%, 40%)
</image>

<image antgs>
/ items = ("<%picture.adantg.currentitem%>")
/ position = (20%,11%)
/ imagesize = (60%, 40%)
</image>

Nicobu
Nicobu
Associate Member
Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)

Group: Forum Members
Posts: 5, Visits: 19
Dave - 11/6/2019
Nicobu - 11/6/2019
Hi, I've created this script to do the SAMP task on Inquisit because i'm running an AMP and other surveys with this script,. I did it on my laptop and it appeared to be ok, but when I moved to the lab (where I'm going to save the data) it displays another one and half of the picture its in HUGE size and I don't know how to "delete" the second image from the script.
Can you help me with that, please? 
I'll appreciate it!!


Here's my script, the first and second images are screenshots of the computer's lab with the problem


Notes: I move pixel by pixel (of the percent in the screen) the sliders, images and texts

You're displaying two versions of the image. First you have the <picture> elements:

<picture adnv>
/ items = advnueva
/ position = (50, 31)
/ size = (60%, 40%)
</picture>

<picture adact>
/ items = advactual
/ position = (50, 31)
/ size = (60%, 40%)
</picture>

<picture adantg>
/ items = advantigua
/ position = (50, 31)
/ size = (60%, 40%)
</picture>

and then the <image> elements:

<image nvs>
/ items = ("<%picture.adnv.currentitem%>")
/ position = (50,31)
</image>

<image acts>
/ items = ("<%picture.adact.currentitem%>")
/ position = (50,31)
</image>

<image antgs>
/ items = ("<%picture.adantg.currentitem%>")
/ position = (50,31)
</image>

Your surveypages display both:

<surveypage RANEF_Nuevas>
/ stimulusframes = [1=adnv]
/ fontstyle = ("Arial", -24, false, true)
/ questions = [1=nvs; 2=slid_rea01; 3=slid_rea02; 4=slid_rea03; 5=slid_fam; 6= descripcionTxtRanef]
/ showpagenumbers = false
/ showquestionnumbers = false
/ finishlabel = "Continuar"
/ nextbuttonposition = (80%, 90%)
</surveypage>

What you should do is:
(1) Move the <picture> elements to off-screen positions:

<picture adnv>
/ items = advnueva
/ position = (-10%, -10%)
/ size = (0%, 0%)
</picture>

<picture adact>
/ items = advactual
/ position = (-10%, -10%)
/ size = (0%, 0%)
</picture>

<picture adantg>
/ items = advantigua
/ position = (-10%, -10%)
/ size = (0%, 0%)
</picture>

(2) Size and position the <image> elements properly:

<image nvs>
/ items = ("<%picture.adnv.currentitem%>")
/ position = (20%,11%)
/ imagesize = (60%, 40%)
</image>

<image acts>
/ items = ("<%picture.adact.currentitem%>")
/ position = (20%,11%)
/ imagesize = (60%, 40%)
</image>

<image antgs>
/ items = ("<%picture.adantg.currentitem%>")
/ position = (20%,11%)
/ imagesize = (60%, 40%)
</image>

Thank you so much!!
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search