Add Audio to Monetary Incentive Delay Task (MID)


Author
Message
devarshivasa
devarshivasa
New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)
Group: Forum Members
Posts: 2, Visits: 17
Hi,

I am an undergrad RA and am trying to add audio accompanying each instruction slide in the MID script available on the Inquisit library. I have tried adding the following but had not luck:

<video audioInstructions>
/ items = ("audiofile1.m4a", "audiofile2.m4a")
/ playthrough = true
/ select = sequence
</video>


I also attempted to separate the two audio files (as shown below) but once again had no luck making the audio work.

<video audioInstructions1>
/items = ("audiofile1.m4a")
/playthrough = true
</video>

<video audioInstructions2
/items = ("audiofile2.m4a")
/playthrough = true
</video>


I've also tried other options as well but was unable to make the audio play. I am using the MID task for Inquisit 5 but am running it on Inquisit 6.

Any advice would be much appreciated! Thanks!
Dave
Dave
Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)Supreme Being (856K reputation)
Group: Administrators
Posts: 10K, Visits: 59K
devarshivasa - 5/29/2020
Hi,

I am an undergrad RA and am trying to add audio accompanying each instruction slide in the MID script available on the Inquisit library. I have tried adding the following but had not luck:

<video audioInstructions>
/ items = ("audiofile1.m4a", "audiofile2.m4a")
/ playthrough = true
/ select = sequence
</video>


I also attempted to separate the two audio files (as shown below) but once again had no luck making the audio work.

<video audioInstructions1>
/items = ("audiofile1.m4a")
/playthrough = true
</video>

<video audioInstructions2
/items = ("audiofile2.m4a")
/playthrough = true
</video>


I've also tried other options as well but was unable to make the audio play. I am using the MID task for Inquisit 5 but am running it on Inquisit 6.

Any advice would be much appreciated! Thanks!

The instructions in the MID are presented via <page> elements and the various /pre- and /postinstructions attributes in the <expt> and <block> elements. You cannot play audio during <page> elements.

That means you have to completely change the way instructions are presented in the task. You need to set up standard <text> elements to present the instructions and add <trial> elements to display them. Those <trial> elements can display the <video> stimulus along with the <text>.

By the way, IF the audio you are trying to add is merely the instructions' text read aloud (you didn't say) AND you will be running this under Inquisit 6, there is an alternative option: Use Inquisit 6's capability to use your system's text-to-speech capabilities to read the instruction pages aloud:
https://www.millisecond.com/support/docs/v6/html/language/attributes/voiceover.htm

<instruct>
/ fontstyle = ("Arial", 3.00%, false, false, false, false, 5, 1)
/ txcolor = (black)
/ voiceover = true(en, male, adult, 0.2)
</instruct>
Edited 5 Months Ago by Dave
devarshivasa
devarshivasa
New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)New Member (7 reputation)
Group: Forum Members
Posts: 2, Visits: 17
Dave - 5/29/2020
devarshivasa - 5/29/2020
Hi,

I am an undergrad RA and am trying to add audio accompanying each instruction slide in the MID script available on the Inquisit library. I have tried adding the following but had not luck:

<video audioInstructions>
/ items = ("audiofile1.m4a", "audiofile2.m4a")
/ playthrough = true
/ select = sequence
</video>


I also attempted to separate the two audio files (as shown below) but once again had no luck making the audio work.

<video audioInstructions1>
/items = ("audiofile1.m4a")
/playthrough = true
</video>

<video audioInstructions2
/items = ("audiofile2.m4a")
/playthrough = true
</video>


I've also tried other options as well but was unable to make the audio play. I am using the MID task for Inquisit 5 but am running it on Inquisit 6.

Any advice would be much appreciated! Thanks!

The instructions in the MID are presented via <page> elements and the various /pre- and /postinstructions attributes in the <expt> and <block> elements. You cannot play audio during <page> elements.

That means you have to completely change the way instructions are presented in the task. You need to set up standard <text> elements to present the instructions and add <trial> elements to display them. Those <trial> elements can display the <video> stimulus along with the <text>.

By the way, IF the audio you are trying to add is merely the instructions' text read aloud (you didn't say) AND you will be running this under Inquisit 6, there is an alternative option: Use Inquisit 6's capability to use your system's text-to-speech capabilities to read the instruction pages aloud:
https://www.millisecond.com/support/docs/v6/html/language/attributes/voiceover.htm

<instruct>
/ fontstyle = ("Arial", 3.00%, false, false, false, false, 5, 1)
/ txcolor = (black)
/ voiceover = true(en, male, adult, 0.2)
</instruct>

Thank you! Appreciate the help!
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search