Survey ID from Inquisit to Qualtrics


Author
Message
aliciay1
aliciay1
New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)
Group: Forum Members
Posts: 12, Visits: 58
Hi, 

I have an experiment set up so it directs from Qualtrics to Inquisit back to Qualtrics. I have the survey id set up following the instructions from here: https://www.millisecond.com/support/docs/v5/html/howto/interopsurveys.htm , which works perfectly. However after directing from Inquisit to Qualtrics - to the secondary Qualtrics survey, the same survey id is not carried over and a new one is generated. 

Does anyone know why this would be occurring? And how it could be set up so the same survey id is carried throughout?

Thanks!
Dave
Dave
Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)
Group: Administrators
Posts: 10K, Visits: 58K
aliciay1 - 6/11/2020
Hi, 

I have an experiment set up so it directs from Qualtrics to Inquisit back to Qualtrics. I have the survey id set up following the instructions from here: https://www.millisecond.com/support/docs/v5/html/howto/interopsurveys.htm , which works perfectly. However after directing from Inquisit to Qualtrics - to the secondary Qualtrics survey, the same survey id is not carried over and a new one is generated. 

Does anyone know why this would be occurring? And how it could be set up so the same survey id is carried throughout?

Thanks!

Please provide the link to the experiment's start page.
Dave
Dave
Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)
Group: Administrators
Posts: 10K, Visits: 58K
Dave - 6/11/2020
aliciay1 - 6/11/2020
Hi, 

I have an experiment set up so it directs from Qualtrics to Inquisit back to Qualtrics. I have the survey id set up following the instructions from here: https://www.millisecond.com/support/docs/v5/html/howto/interopsurveys.htm , which works perfectly. However after directing from Inquisit to Qualtrics - to the secondary Qualtrics survey, the same survey id is not carried over and a new one is generated. 

Does anyone know why this would be occurring? And how it could be set up so the same survey id is carried throughout?

Thanks!

Please provide the link to the experiment's start page.

Since you've not (yet) shared your particular experiment and I thus cannot check whether its settings are correct, a few general remarks:

(1) Any URL parameter that comes in to the Inquisit start page is automatically preserved and automatically appended to the URL you specified for redirection after the experiment in the web experiment settings. So, if you have

https://mili2nd.co/elob?subjectid=abc123

with the URL parameter called "subjectid" coming in, and specify https://www.example.com/ as the URL to redirect to



then you'll automatically be redirected to

https://www.example.com/?subjectid=abc123

Try it for yourself, the launch link is functional.

(2) Specifying a redirection like this



is only necessary if the subjectid isn't coming in via URL parameter to begin with. I.e. if your whole procedure starts with Inquisit and you then wish to pass Inquisit's (typically randomly generated) participant identifier on to another site.

(3) Whatever other site (in your case, a 2nd Qualtrics survey) you redirect to after, you need to set that survey up to read in the relevant URL parameter, here: The one called "subjectid". For Qualtrics, you will find this covered in their documentation at https://www.qualtrics.com/support/survey-platform/survey-module/survey-flow/standard-elements/passing-information-through-query-strings#PassingInformationIntoASurvey

Edited 2 Months Ago by Dave
aliciay1
aliciay1
New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)
Group: Forum Members
Posts: 12, Visits: 58
Dave - 6/12/2020
Dave - 6/11/2020
aliciay1 - 6/11/2020
Hi, 

I have an experiment set up so it directs from Qualtrics to Inquisit back to Qualtrics. I have the survey id set up following the instructions from here: https://www.millisecond.com/support/docs/v5/html/howto/interopsurveys.htm , which works perfectly. However after directing from Inquisit to Qualtrics - to the secondary Qualtrics survey, the same survey id is not carried over and a new one is generated. 

Does anyone know why this would be occurring? And how it could be set up so the same survey id is carried throughout?

Thanks!

Please provide the link to the experiment's start page.

Since you've not (yet) shared your particular experiment and I thus cannot check whether its settings are correct, a few general remarks:
(1) Any URL parameter that comes in to the Inquisit start page is automatically preserved and automatically appended to the URL you specified for redirection after the experiment in the web experiment settings. So, if you have

https://mili2nd.co/elob?subjectid=abc123

with the URL parameter called "subjectid" coming in, and specify https://www.example.com/ as the URL to redirect to



then you'll automatically be redirected to

https://www.example.com/?subjectid=abc123

Try it for yourself, the launch link is functional.

(2) Specifying a redirection like this



is only necessary if the subjectid isn't coming in via URL parameter to begin with. I.e. if your whole procedure starts with Inquisit and you then wish to pass Inquisit's (typically randomly generated) participant identifier on to another site.

(3) Whatever other site (in your case, a 2nd Qualtrics survey) you redirect to after, you need to set that survey up to read in the relevant URL parameter, here: The one called "subjectid". For Qualtrics, you will find this covered in their documentation here: https://www.qualtrics.com/support/survey-platform/survey-module/survey-flow/standard-elements/passing-information-through-query-strings#PassingInformationIntoASurvey

Thank you so much! I just had to add in the last step and it now works.
Dave
Dave
Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)
Group: Administrators
Posts: 10K, Visits: 58K
aliciay1 - 6/12/2020
Dave - 6/12/2020
Dave - 6/11/2020
aliciay1 - 6/11/2020
Hi, 

I have an experiment set up so it directs from Qualtrics to Inquisit back to Qualtrics. I have the survey id set up following the instructions from here: https://www.millisecond.com/support/docs/v5/html/howto/interopsurveys.htm , which works perfectly. However after directing from Inquisit to Qualtrics - to the secondary Qualtrics survey, the same survey id is not carried over and a new one is generated. 

Does anyone know why this would be occurring? And how it could be set up so the same survey id is carried throughout?

Thanks!

Please provide the link to the experiment's start page.

Since you've not (yet) shared your particular experiment and I thus cannot check whether its settings are correct, a few general remarks:
(1) Any URL parameter that comes in to the Inquisit start page is automatically preserved and automatically appended to the URL you specified for redirection after the experiment in the web experiment settings. So, if you have

https://mili2nd.co/elob?subjectid=abc123

with the URL parameter called "subjectid" coming in, and specify https://www.example.com/ as the URL to redirect to



then you'll automatically be redirected to

https://www.example.com/?subjectid=abc123

Try it for yourself, the launch link is functional.

(2) Specifying a redirection like this



is only necessary if the subjectid isn't coming in via URL parameter to begin with. I.e. if your whole procedure starts with Inquisit and you then wish to pass Inquisit's (typically randomly generated) participant identifier on to another site.

(3) Whatever other site (in your case, a 2nd Qualtrics survey) you redirect to after, you need to set that survey up to read in the relevant URL parameter, here: The one called "subjectid". For Qualtrics, you will find this covered in their documentation here: https://www.qualtrics.com/support/survey-platform/survey-module/survey-flow/standard-elements/passing-information-through-query-strings#PassingInformationIntoASurvey

Thank you so much! I just had to add in the last step and it now works.

Wonderful, thanks for letting me know!
Edited 2 Months Ago by Dave
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search