Automatic grant credit with qualtrics study


Author
Message
xizhouxie
xizhouxie
Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)
Group: Forum Members
Posts: 21, Visits: 91
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      
Dave
Dave
Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)
Group: Administrators
Posts: 10K, Visits: 62K
xizhouxie - 10/26/2020
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      

> 5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?

If you want Inquisit to read in the subjectid URL parameter (and that is what you want), you ought to set



in your web experiment's settings, not random subject ID generation.

xizhouxie
xizhouxie
Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)
Group: Forum Members
Posts: 21, Visits: 91
Dave - 10/26/2020
xizhouxie - 10/26/2020
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      

> 5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?

If you want Inquisit to read in the subjectid URL parameter (and that is what you want), you ought to set



in your web experiment's settings, not random subject ID generation.

I did that first and here is the error message
In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'
Dave
Dave
Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)
Group: Administrators
Posts: 10K, Visits: 62K
xizhouxie - 10/26/2020
Dave - 10/26/2020
xizhouxie - 10/26/2020
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      

> 5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?

If you want Inquisit to read in the subjectid URL parameter (and that is what you want), you ought to set



in your web experiment's settings, not random subject ID generation.

I did that first and here is the error message
In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

> In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

Then you're not passing the URL parameter over from Qualtrics properly. That's where you need to look for the mistake.
xizhouxie
xizhouxie
Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)
Group: Forum Members
Posts: 21, Visits: 91
Dave - 10/26/2020
xizhouxie - 10/26/2020
Dave - 10/26/2020
xizhouxie - 10/26/2020
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      

> 5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?

If you want Inquisit to read in the subjectid URL parameter (and that is what you want), you ought to set



in your web experiment's settings, not random subject ID generation.

I did that first and here is the error message
In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

> In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

Then you're not passing the URL parameter over from Qualtrics properly. That's where you need to look for the mistake.

does that mean step 4 is wrong?
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
Dave
Dave
Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)Supreme Being (871K reputation)
Group: Administrators
Posts: 10K, Visits: 62K
xizhouxie - 10/26/2020
Dave - 10/26/2020
xizhouxie - 10/26/2020
Dave - 10/26/2020
xizhouxie - 10/26/2020
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      

> 5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?

If you want Inquisit to read in the subjectid URL parameter (and that is what you want), you ought to set



in your web experiment's settings, not random subject ID generation.

I did that first and here is the error message
In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

> In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

Then you're not passing the URL parameter over from Qualtrics properly. That's where you need to look for the mistake.

does that mean step 4 is wrong?
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}

The description is correct, but if Inquisit tells you the parameter isn't there, it isn't. In other words, your description does not match your actual Qualtrics setup. You have a mistake somewhere in there and need to double-check it.
xizhouxie
xizhouxie
Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)Associate Member (131 reputation)
Group: Forum Members
Posts: 21, Visits: 91
Dave - 10/26/2020
xizhouxie - 10/26/2020
Dave - 10/26/2020
xizhouxie - 10/26/2020
Dave - 10/26/2020
xizhouxie - 10/26/2020
I have a study hosted in sona. It sends people to qualtrics first, then milisecond, and that's where they finish and get credit. Here is what I have done so far:

1. Sona study url: https://uwmadison.co1.qualtrics.com/jfe/form/SV_bBEVTkvsNaXPv5H?id=%SURVEY_CODE%   
2. The link that participants click (generated by sona): https://uwmadison.sona-systems.com/default.aspx?p_return_experiment_id=1696                             
3. Within qualtrics survey flow, I embedded "id" (for step 1)
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}
5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?
6. And finally, on milisecond the finish page is set to: https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%>">https://uwmadison.sona-systems.com/webstudy_credit.aspx?experiment_id=1696&credit_token=85c9eade3b254378b1413cf3d66a9fb0&survey_code=<%script.subjectid%> where the subjectid should be the same as id=%SURVEY_CODE%  in the first step. 

Participants can finish the qualtrics survey and inquisit study without issue, but they are not granted credits. Could you tell me what I did wrong?
                      

> 5. On milisecond, the subject id is set to random selection. However it should be overwritten by the "id" right?

If you want Inquisit to read in the subjectid URL parameter (and that is what you want), you ought to set



in your web experiment's settings, not random subject ID generation.

I did that first and here is the error message
In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

> In case the image doesn't work (I'm having issues with uploads) it says "unable to get subject id from URL parameter 'subjectid'

Then you're not passing the URL parameter over from Qualtrics properly. That's where you need to look for the mistake.

does that mean step 4 is wrong?
4. End of qualtrics link (to milisecond): https://mili2nd.co/euvb?subjectid=${e://Field/id}

The description is correct, but if Inquisit tells you the parameter isn't there, it isn't. In other words, your description does not match your actual Qualtrics setup. You have a mistake somewhere in there and need to double-check it.

tried it again and it worked. not sure why it wasn't working before
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search