Getting subject ID to flow from Qualtrics to Inquisit and back to Qualtrics


Author
Message
barnhart135
barnhart135
Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)
Group: Forum Members
Posts: 11, Visits: 22
Hello!

Colleagues and I are working on a study where we have folks start out in Qualtrics, forward to Inquisit, and back to another Qualtrics to close the study.

We have correctly terminated the Qualtrics survey with our online link to the Inquisit study, and we included "?subjectid=${e://Field/ResponseID}" at the end of the online link.

When then link BACK to another survey, but per this link: https://www.millisecond.com/support/docs/v6/html/howto/interopsurveys.htm
we "Do not specify the subject id in the Finish Page url - Inquisit will automatically append the id using the same query parameter that it found when the subject arrived at the Inquisit launch page."

When we look at the data file for the second Qualtrics survey, the subject ID does not match that from the first Qualtrics survey and the data in Inquisit. Any leads on how to fix this issue so that the ID is the same on all platforms?
barnhart135
barnhart135
Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)
Group: Forum Members
Posts: 11, Visits: 22
barnhart135 - 1/23/2021
Hello!

Colleagues and I are working on a study where we have folks start out in Qualtrics, forward to Inquisit, and back to another Qualtrics to close the study.

We have correctly terminated the Qualtrics survey with our online link to the Inquisit study, and we included "?subjectid=${e://Field/ResponseID}" at the end of the online link.

When then link BACK to another survey, but per this link: https://www.millisecond.com/support/docs/v6/html/howto/interopsurveys.htm
we "Do not specify the subject id in the Finish Page url - Inquisit will automatically append the id using the same query parameter that it found when the subject arrived at the Inquisit launch page."

When we look at the data file for the second Qualtrics survey, the subject ID does not match that from the first Qualtrics survey and the data in Inquisit. Any leads on how to fix this issue so that the ID is the same on all platforms?

Just wanted to bump this to hopefully get some advice - thanks!
Dave
Dave
Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)
Group: Administrators
Posts: 11K, Visits: 65K
barnhart135 - 1/24/2021
barnhart135 - 1/23/2021
Hello!

Colleagues and I are working on a study where we have folks start out in Qualtrics, forward to Inquisit, and back to another Qualtrics to close the study.

We have correctly terminated the Qualtrics survey with our online link to the Inquisit study, and we included "?subjectid=${e://Field/ResponseID}" at the end of the online link.

When then link BACK to another survey, but per this link: https://www.millisecond.com/support/docs/v6/html/howto/interopsurveys.htm
we "Do not specify the subject id in the Finish Page url - Inquisit will automatically append the id using the same query parameter that it found when the subject arrived at the Inquisit launch page."

When we look at the data file for the second Qualtrics survey, the subject ID does not match that from the first Qualtrics survey and the data in Inquisit. Any leads on how to fix this issue so that the ID is the same on all platforms?

Just wanted to bump this to hopefully get some advice - thanks!

You need to configure your 2nd Qualtrics survey to read the original ID back in, by setting it up to read the value of the subjectid URL parameter per Qualtrics' "embedded data" facilities.

https://www.qualtrics.com/support/survey-platform/survey-module/survey-flow/standard-elements/passing-information-through-query-strings/#PassingInformationIntoASurvey


barnhart135
barnhart135
Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)
Group: Forum Members
Posts: 11, Visits: 22
Hi Dave--

This is helpful. I am still a bit confused. Can you help me understand what you mean by the value of the subjectid URL parameter? Are you referring to this information "?subjectid=${e://Field/ResponseID}"

Apologies - first time working through these issues. Some more detailed instructions would be super helpful
Dave
Dave
Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)Supreme Being (914K reputation)
Group: Administrators
Posts: 11K, Visits: 65K
barnhart135 - 1/25/2021
AHi Dave--

This is helpful. I am still a bit confused. Can you help me understand what you mean by the value of the subjectid URL parameter? Are you referring to this information "?subjectid=${e://Field/ResponseID}"

Apologies - first time working through these issues. Some more detailed instructions would be super helpful

URL parameters are name-value pairs. "subjectid" is the parameters name, what follows after the = is the value.

Your first Qualtrics survey forwards the URL parameters subjectid to Inquisit, dynamically filling in a given participants Qualtrics response ID as its value per

"?subjectid=${e://Field/ResponseID}"

So, for a participant who has been assigned the ID "abc123" by Qualtrics, it will redirect to your Inquisit start page like so

mili2nd.co/yourexperimentsshortcode?subjectid=abc123

Inquisit will forward the same parameter and value to the 2nd Qualtrics survey when it redirects there. That survey ought read in the parameter's value as described in the Qualtircs documentation topic I linked for you. Otherwise the 2nd Qualtrics survey will just ignore the parameter, i.e. it will not log it to its data.

https://www.millisecond.com/forums/FindPost29950.aspx

These really are Qualtrics questions, though, so for anything further Qualtrics support staff would be better equipped to address them.

Edited 2 Months Ago by Dave
barnhart135
barnhart135
Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)Associate Member (54 reputation)
Group: Forum Members
Posts: 11, Visits: 22
Thank you, Dave!
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search