Issues with Inquisit Web


Author
Message
Haniel_Do
Haniel_Do
New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)
Group: Forum Members
Posts: 12, Visits: 55
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
Haniel_Do
Haniel_Do
New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)
Group: Forum Members
Posts: 12, Visits: 55
Haniel_Do - 6/23/2021
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
For some reason the I can't see the image I added above so I attached it below.
Attachments
Capture.PNG (14 views, 915.00 KB)
Dave
Dave
Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)
Group: Administrators
Posts: 11K, Visits: 71K
Haniel_Do - 6/23/2021
Haniel_Do - 6/23/2021
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
For some reason the I can't see the image I added above so I attached it below.

It's not possible to say anything about this without you providing the script and associated materials and the link to the online study.

In general, you should use the Inquisit Lab version to code and test the script that corresponds to the Inquisit Web version you will be using to collect data.

Haniel_Do
Haniel_Do
New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)
Group: Forum Members
Posts: 12, Visits: 55
Dave - 6/23/2021
Haniel_Do - 6/23/2021
Haniel_Do - 6/23/2021
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
For some reason the I can't see the image I added above so I attached it below.

It's not possible to say anything about this without you providing the script and associated materials and the link to the online study.

In general, you should use the Inquisit Lab version to code and test the script that corresponds to the Inquisit Web version you will be using to collect data.

Hi Dave,

Sorry I didn't want to make the post too long. Essentially this is the script for my page:

<defaults>
/ Canvassize=(90%, 90%)
</defaults>

<page intro>
^^^^^^^^SRM Task
^^^Welcome and thank you for participating
^^^Please press the spacebar to continue
</page>

<page encoding>
^^^This task will require you to group words into one of two categories, there are three sets of categories:
^^Desirable vs. Undesirable: For this category choice please choose whether the word presented is seen as social desirable (Press E) or undersirable (Press I).
^^Uppercase vs. Lowercase: For this category choice please choose dependant on whether the first letter in the word is uppercase (Press E) or lowercase (Press I).
^^Me vs. Not me: For this category choice, please choose whether the word presented describes yourself (Press E) or not (Press I).
^^Instructions will remain in the top left and righ corners of the screen in case you forget.
</page>

And then this is my script for the blocks I wish to record data for:

<block encoding>
/ preinstructions = ( intro, encoding)
/ postinstructions = (encodingfinish)
/ trials = [1-78 = noreplace (a,b,c,d,e,f)]
/ recorddata = true
</block>

<block Recognition>
/ preinstructions = (RecognitionInstructions)
/ postinstructions = (finalpage)
/ trials = [1-156 = noreplace (g,h)]
/ recorddata = true
</block>

There are some blocks in between which are a distractor task I am not recording. If there was any help you could provide I would greatly appreciate it. Thanks, Daniel
Dave
Dave
Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)
Group: Administrators
Posts: 11K, Visits: 71K
Haniel_Do - 6/24/2021
Dave - 6/23/2021
Haniel_Do - 6/23/2021
Haniel_Do - 6/23/2021
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
For some reason the I can't see the image I added above so I attached it below.

It's not possible to say anything about this without you providing the script and associated materials and the link to the online study.

In general, you should use the Inquisit Lab version to code and test the script that corresponds to the Inquisit Web version you will be using to collect data.

Hi Dave,

Sorry I didn't want to make the post too long. Essentially this is the script for my page:

<defaults>
/ Canvassize=(90%, 90%)
</defaults>

<page intro>
^^^^^^^^SRM Task
^^^Welcome and thank you for participating
^^^Please press the spacebar to continue
</page>

<page encoding>
^^^This task will require you to group words into one of two categories, there are three sets of categories:
^^Desirable vs. Undesirable: For this category choice please choose whether the word presented is seen as social desirable (Press E) or undersirable (Press I).
^^Uppercase vs. Lowercase: For this category choice please choose dependant on whether the first letter in the word is uppercase (Press E) or lowercase (Press I).
^^Me vs. Not me: For this category choice, please choose whether the word presented describes yourself (Press E) or not (Press I).
^^Instructions will remain in the top left and righ corners of the screen in case you forget.
</page>

And then this is my script for the blocks I wish to record data for:

<block encoding>
/ preinstructions = ( intro, encoding)
/ postinstructions = (encodingfinish)
/ trials = [1-78 = noreplace (a,b,c,d,e,f)]
/ recorddata = true
</block>

<block Recognition>
/ preinstructions = (RecognitionInstructions)
/ postinstructions = (finalpage)
/ trials = [1-156 = noreplace (g,h)]
/ recorddata = true
</block>

There are some blocks in between which are a distractor task I am not recording. If there was any help you could provide I would greatly appreciate it. Thanks, Daniel

I cannot help you on that basis. I asked you to provide the script, materials, and the link to the online study. I also asked you, albeit only implicitly, to provide version information, i.e.: Which Inquisit Lab version did you code this with and which Inquisit Web version are you administering this with? The likely problem is that you've used different versions and are running a script coded in and relying on features of Inquisit 5 under Inquisit 4 Web.

Please provide the information I asked for.
Edited 2 Months Ago by Dave
Haniel_Do
Haniel_Do
New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)New Member (32 reputation)
Group: Forum Members
Posts: 12, Visits: 55
Dave - 6/24/2021
Haniel_Do - 6/24/2021
Dave - 6/23/2021
Haniel_Do - 6/23/2021
Haniel_Do - 6/23/2021
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
For some reason the I can't see the image I added above so I attached it below.

It's not possible to say anything about this without you providing the script and associated materials and the link to the online study.

In general, you should use the Inquisit Lab version to code and test the script that corresponds to the Inquisit Web version you will be using to collect data.

Hi Dave,

Sorry I didn't want to make the post too long. Essentially this is the script for my page:

<defaults>
/ Canvassize=(90%, 90%)
</defaults>

<page intro>
^^^^^^^^SRM Task
^^^Welcome and thank you for participating
^^^Please press the spacebar to continue
</page>

<page encoding>
^^^This task will require you to group words into one of two categories, there are three sets of categories:
^^Desirable vs. Undesirable: For this category choice please choose whether the word presented is seen as social desirable (Press E) or undersirable (Press I).
^^Uppercase vs. Lowercase: For this category choice please choose dependant on whether the first letter in the word is uppercase (Press E) or lowercase (Press I).
^^Me vs. Not me: For this category choice, please choose whether the word presented describes yourself (Press E) or not (Press I).
^^Instructions will remain in the top left and righ corners of the screen in case you forget.
</page>

And then this is my script for the blocks I wish to record data for:

<block encoding>
/ preinstructions = ( intro, encoding)
/ postinstructions = (encodingfinish)
/ trials = [1-78 = noreplace (a,b,c,d,e,f)]
/ recorddata = true
</block>

<block Recognition>
/ preinstructions = (RecognitionInstructions)
/ postinstructions = (finalpage)
/ trials = [1-156 = noreplace (g,h)]
/ recorddata = true
</block>

There are some blocks in between which are a distractor task I am not recording. If there was any help you could provide I would greatly appreciate it. Thanks, Daniel

I cannot help you on that basis. I asked you to provide the script, materials, and the link to the online study. I also asked you, albeit only implicitly, to provide version information, i.e.: Which Inquisit Lab version did you code this with and which Inquisit Web version are you administering this with? The likely problem is that you've used different versions and are running a script coded in and relying on features of Inquisit 5 under Inquisit 4 Web.

Please provide the information I asked for.

Hi Dave,

Sorry I didn't realise you meant the whole script, I've attached it here. There are stimuli pictures that come with it but those go over the limit of what I'm allowed to upload space wise so I couldn't add them. The version I am using is 4 however the lab is for 5, the links provided to me only gave me lab for Inquisit 5. Finally this is the link to the online study: https://research.millisecond.com/dskvarc/selfreferentialmemorytask.web if you could use participant ID 0101 so that I know which one to delete later I'd appreciate it. Thanks

Daniel
Attachments
Dave
Dave
Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)Supreme Being (950K reputation)
Group: Administrators
Posts: 11K, Visits: 71K
Haniel_Do - 6/25/2021
Dave - 6/24/2021
Haniel_Do - 6/24/2021
Dave - 6/23/2021
Haniel_Do - 6/23/2021
Haniel_Do - 6/23/2021
Hi all,

I was having some issues with my script which ran perfectly fine on Inquisit lab and was wondering if anyone could help me out with some recommendations. Firstly, one of my pages is showing up different for some reason in the web version, with the buttons blocking the text as shown below.  I looked on the forums and saw the other posts about this, I tried the canvas size and nextkey recommendations but they didn't fix it so I was wondering if anyone is having this issue or has another solution. In addition, for some reason my responses aren't being recorded. While I have "/ recorddata = true" on the blocks I want recorded, when I click view log nothing comes up at all, as if it didn't even recognise that an attempt had been made. If anyone had any advice or tips on how to fix this I would appreciate it. Thanks

Daniel
For some reason the I can't see the image I added above so I attached it below.

It's not possible to say anything about this without you providing the script and associated materials and the link to the online study.

In general, you should use the Inquisit Lab version to code and test the script that corresponds to the Inquisit Web version you will be using to collect data.

Hi Dave,

Sorry I didn't want to make the post too long. Essentially this is the script for my page:

<defaults>
/ Canvassize=(90%, 90%)
</defaults>

<page intro>
^^^^^^^^SRM Task
^^^Welcome and thank you for participating
^^^Please press the spacebar to continue
</page>

<page encoding>
^^^This task will require you to group words into one of two categories, there are three sets of categories:
^^Desirable vs. Undesirable: For this category choice please choose whether the word presented is seen as social desirable (Press E) or undersirable (Press I).
^^Uppercase vs. Lowercase: For this category choice please choose dependant on whether the first letter in the word is uppercase (Press E) or lowercase (Press I).
^^Me vs. Not me: For this category choice, please choose whether the word presented describes yourself (Press E) or not (Press I).
^^Instructions will remain in the top left and righ corners of the screen in case you forget.
</page>

And then this is my script for the blocks I wish to record data for:

<block encoding>
/ preinstructions = ( intro, encoding)
/ postinstructions = (encodingfinish)
/ trials = [1-78 = noreplace (a,b,c,d,e,f)]
/ recorddata = true
</block>

<block Recognition>
/ preinstructions = (RecognitionInstructions)
/ postinstructions = (finalpage)
/ trials = [1-156 = noreplace (g,h)]
/ recorddata = true
</block>

There are some blocks in between which are a distractor task I am not recording. If there was any help you could provide I would greatly appreciate it. Thanks, Daniel

I cannot help you on that basis. I asked you to provide the script, materials, and the link to the online study. I also asked you, albeit only implicitly, to provide version information, i.e.: Which Inquisit Lab version did you code this with and which Inquisit Web version are you administering this with? The likely problem is that you've used different versions and are running a script coded in and relying on features of Inquisit 5 under Inquisit 4 Web.

Please provide the information I asked for.

Hi Dave,

Sorry I didn't realise you meant the whole script, I've attached it here. There are stimuli pictures that come with it but those go over the limit of what I'm allowed to upload space wise so I couldn't add them. The version I am using is 4 however the lab is for 5, the links provided to me only gave me lab for Inquisit 5. Finally this is the link to the online study: https://research.millisecond.com/dskvarc/selfreferentialmemorytask.web if you could use participant ID 0101 so that I know which one to delete later I'd appreciate it. Thanks

Daniel

> The version I am using is 4 however the lab is for 5,

Well, there's your problem. You are running something that assumes Inquisit 5 features and defaults under Inquisit 4. Don't do that. Code and test the scripts using the Lab version corresponding to the Web version you will be using to gather data.

As for availability, Inquisit 4 Lab is available per the site's download archives: https://www.millisecond.com/download/archives.aspx

As for the script itself, define a proper /windowsize in <instruct> if you want instruction pages to have a larger area available for the instruction text. You should also fix the typos in many of your trial elements, where / correctresponse is misspelled as / correctreponse, i missing an "s". As for not recording data, multiple blocks in the script are set to not record data per / recorddata = false, but that looks deliberate (I assume these are the distractor task). Data is recorded only for the encoding and the recognition blocks.

Edited 2 Months Ago by Dave
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search