Redirection to Unipark


Author
Message
Lisa Leonie24
Lisa Leonie24
New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)
Group: Forum Members
Posts: 4, Visits: 10
Hi,

I’ve got the following situation: after a first survey on Unipark the participants are directed to Implicit. After they have completed the experiment on Implicit they are supposed to be redirected to the first survey on Unipark. I’ve got the following link for the redirection to Unipark

https://ww2.unipark.de/uc/HFT_Stuttgart_Studenten/8cf8/ospe.php?return_tic=n


tic is the individual participant identifier which is necessary that the participants can be identified and are redirected to the right point within the Unipark survey.

I’ve entered this Link at the settings for Finish page when I chose the option „send participants to a url“.

When I entered the link (https://ww2.unipark.de/uc/HFT_Stuttgart_Studenten/8cf8/ospe.php?return_tic=n) the redirection didn’t work at all and I just got an error message when I finished the experiment on Implicit. I then changed the link to:

https://ww2.unipark.de/uc/HFT_Stuttgart_Studenten/8cf8/ospe.php?#return_tic=n#

So tic is identified as variable. With this link the redirection to unipark works but I am redirected to the page I’ve seen before I am directed to Implicit and when I want to get to the next page I am again redirected to Implicit, so this creates a loop and I am not able to finish the survey on Unipark.

I’ve been in touch with the Unipark support and they’ve told me that this has to be an issue with Implicit. More precisely with the participant identifier. Probably the participant identifier is not passed on correctly and therefore I am not redirected to the right point within the survey.


The Experiment ID is 61615

Any help would be appreciated very much!
Dave
Dave
Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)Supreme Being (974K reputation)
Group: Administrators
Posts: 11K, Visits: 76K
Lisa Leonie24 - 11/2/2021
Hi,

I’ve got the following situation: after a first survey on Unipark the participants are directed to Implicit. After they have completed the experiment on Implicit they are supposed to be redirected to the first survey on Unipark. I’ve got the following link for the redirection to Unipark

https://ww2.unipark.de/uc/HFT_Stuttgart_Studenten/8cf8/ospe.php?return_tic=n


tic is the individual participant identifier which is necessary that the participants can be identified and are redirected to the right point within the Unipark survey.

I’ve entered this Link at the settings for Finish page when I chose the option „send participants to a url“.

When I entered the link (https://ww2.unipark.de/uc/HFT_Stuttgart_Studenten/8cf8/ospe.php?return_tic=n) the redirection didn’t work at all and I just got an error message when I finished the experiment on Implicit. I then changed the link to:

https://ww2.unipark.de/uc/HFT_Stuttgart_Studenten/8cf8/ospe.php?#return_tic=n#

So tic is identified as variable. With this link the redirection to unipark works but I am redirected to the page I’ve seen before I am directed to Implicit and when I want to get to the next page I am again redirected to Implicit, so this creates a loop and I am not able to finish the survey on Unipark.

I’ve been in touch with the Unipark support and they’ve told me that this has to be an issue with Implicit. More precisely with the participant identifier. Probably the participant identifier is not passed on correctly and therefore I am not redirected to the right point within the survey.


The Experiment ID is 61615

Any help would be appreciated very much!



This makes no sense. First, it's not valid syntax. Second, how is Inquisit supposed to know what "return_tic" is supposed to be? There is absolutely nothing that would tell it that.

Look, coming from Unipark, you have Inquisit read in a URL parameter called "tic" as the subject ID:



That parameter Inquisit will automatially append to whatever outgoing URL you specify. But it's called "tic", not "return_tic".

If you want that previously read in ID to be pushed back in a URL parameter called "return_tic", then the proper sytnax for that is



as detailed at https://www.millisecond.com/support/docs/v6/html/howto/interopsurveys.htm

Lisa Leonie24
Lisa Leonie24
New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)New Member (14 reputation)
Group: Forum Members
Posts: 4, Visits: 10
Hi Dave,
I tried the URL you proposed and everything works perfectly fine.

Thank you very much for your help!
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search