Problem with openended trial element


Author
Message
kfenn
kfenn
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 5, Visits: 5

Hello,


we are having on odd issue with the openended trial element.  we would like to code the answers as correct/incorrect and the script will do this just fine if we have participants click on the button to advance (i.e. using / mouse = true).  however, there are a lot of trials and i would like them to be able to simply press enter to advance.  The problem is that if the text screen is > 1 line, then inquisit does not code any valid answers as correct.  It seems to add the return into their response or something.  If I change it so that / numlines = 1, then the program will code correct/incorrect appropriately, but i get this weird 'bloop' sound every time I hit enter!  It sounds like an error-type signal... but i get it for ALL responses.  Note: I do not get this weird sound if / numlines = 2. There is an example of a trial below, in case that helps.


Has anyone encountered this and if so, can you please advise?


Many thanks,


~Kim


<openended stag>
/stimulustimes = [0=stagstim]
/ response = anyresponse
/ correctresponse = ("stagg", "stag")
/ mouse=false
/ pretrialpause = 750
/ posttrialpause = 200
/ fontstyle = ("Times New Roman", 2.44%, false, false, false, false, 5, 0)
/ position= (50, 55)
/ charlimit = 1000
/ numlines = 1
/ linelength = 40
/ buttonlabel = "Press Enter after responding"
</openended>


seandr
seandr
Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)
Group: Administrators
Posts: 1.3K, Visits: 1K

Hi Kim,


Previously, the openended response required you to press Ctrl+Enter to respond via keyboard, whereas pressing Enter just inserted a line break. It appears that Enter now advances to the next trial and inserts a line break, which causes the response to be different than those listed in the /correctresponse list.


I'll get this sorted out in the next build. In the meantime, there are a couple of workarounds


1) You can actually include the line breaks in the /correctresponse options. (This is a bit of a hack so you may want to hold your nose [:S] )


<openended stag>
/stimulustimes = [0=stagstim]
/ response = anyresponse
/ correctresponse = ("stagg", "stag", "stagg
", "stag
")
/ mouse=false
/ pretrialpause = 750
/ posttrialpause = 200
/ fontstyle = ("Times New Roman", 2.44%, false, false, false, false, 5, 0)
/ position= (50, 55)
/ charlimit = 1000
/ numlines = 1
/ linelength = 40
/ buttonlabel = "Press Enter after responding"
</openended>


2. Or you can take advantage of the relatively new /iscorrectresponse command, which enables you to determine correctness using expressions. In your case, you could strip the new line characters from the response as follows:


/ iscorrectresponse = ["stag" == trimright(openended.stag.response, "~n" || "stagg" == trimright(openended.stag.response, "~n"]


Hope this helps,
Sean


kfenn
kfenn
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 5, Visits: 5

Hi Sean,


Thanks so much for replying!  I tried using line breaks with the / correctresponse command earlier, but they do not work. I tried it again after receiving your message, but still no luck.


Also, I've been trying to use the iscorrectresponse syntax that you sent, but i can't seem to get that to work at all. I've tried it several different ways and usually get an error message.  However, even if the program runs, it does not code the response accurately.  I've also tried substituting the ~n for the scancode for enter, among other things...


Everything works perfectly if I keep the text box to only one line, but then i get that weird windows error 'bloop sound'.  Do you have any idea how I can avoid this?  The major problem is that we are using auditory stimuli and are trying to give error feedback... (I sent you the 'simple' version of the trial).


Thank you!


~Kim


seandr
seandr
Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)Supreme Being (127K reputation)
Group: Administrators
Posts: 1.3K, Visits: 1K

I'm pretty sure the "bloop" sound is controlled via a Windows setting, because I don't hear it on my computer.


If you go to Control Panel and find the applet for Sound or Audio, you can configure Windows to play (or not play) various sounds when certain events occur. I'm not sure which event this is, but if you scroll through the events and play the sounds corresponding to each one, you'll know you've found the right when you hear that old familiar "bloop". You can then turn that sound off.


Hope this helps, but let me know if not.


-Sean




kfenn
kfenn
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 5, Visits: 5

You're brilliant!  Or maybe i just overlook the obvious....



Either way - it works!  Thanks so much!!!


~Kim


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search