Survey Selection


Survey Selection

Author
Message
Roar86
Roar86
Partner Member
Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)

Group: Forum Members
Posts: 11, Visits: 1


Hi there,


I’m a new user and I have been enjoying developing my experiment
so far but I have hit a dead end. In my experiment I have a simple survey in
which people select items (text) from a list of 20 possible options. What I
want to do is show on subsequent pages the individual items the participants
selected and ask questions relating to them. Is this possible?


Additionally, after the participants select the items, is it
possible to show a single selected item and a single non-selected item on the
same page?


Cheers,


Roar



Dave
Dave
Supreme Being
Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K

For starters check out the "Create Stimuli from responses to a questionnaire" script available at the Inquisit Task Library:


http://www.millisecond.com/download/samples/v3/selectitems/selectitems.zip


Then go on to study these threads:


http://www.millisecond.com/forums/Topic3875.aspx


http://www.millisecond.com/community/forums/t/1276.aspx


That should get you going.


~Dave


Roar86
Roar86
Partner Member
Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)

Group: Forum Members
Posts: 11, Visits: 1

Hi Dave,


Thanks for your quick response. I have taken your advice and have ended up with a paradigm that is almost functioning perfectly. I think my problem is a minor one but after hours of hacking away I just can't figure it out. When I'm selecting the items in the survey I need to click "finish" twice before it shows me my selected and unselected items. Is there an easy fix for this?


Cheers,


Roar


Attachments
DV_TEMPLATE5_OUTPUT WORKING!!!!4.exp (464 views, 13.00 KB)
Dave
Dave
Supreme Being
Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K

Happens because you're actually having <surveypage grouppage> run twice:


(1) First time via


<survey selectionphase>
/ pages = [1=grouppage]
[...]
</survey>


(2) Second time via


<block showchoices>
/ trials = [1 = grouppage; 2 = summary]
</block>


Note that the <survey> element is just a special kind of <block> element. Similarly, the <surveypage> element is just a special type of <trial> element. To fix things, eliminate grouppage from <block showchoices> and set up an <expt> element to run <survey selectionphase> and <block showchoices> in the correct order:


<expt>
/ blocks = [1=selectionphase; 2=showchoices]
[...]
</expt>


<survey selectionphase>

/ pages = [1=grouppage]

[...]

</survey>


<block showchoices>

/ trials = [1 = summary]

</block>


Regards,


~Dave


Roar86
Roar86
Partner Member
Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)

Group: Forum Members
Posts: 11, Visits: 1

Hey Dave,


Sorry to keep asking, I just gave it a go and now and it's taking only one attempt to select the items but no output is coming up when i'm trying to show choices.


Cheers,


Rory


Attachments
Dave
Dave
Supreme Being
Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K

(1) <survey selectionphase> is defined twice in the script you attached.


(2) After removing the redundant <survey> element, the script runs fine on my system (tested with 3.0.4.0).


~Dave


Roar86
Roar86
Partner Member
Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)Partner Member (836 reputation)

Group: Forum Members
Posts: 11, Visits: 1

Dave you are a champion. Thank you very much.



Dave
Dave
Supreme Being
Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)Supreme Being (679K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K

Works now, I take it? In any case, good luck with your further programming endeavors!


~Dave


GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search