Urgent: batch crashes


Author
Message
Lieke
Lieke
Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)
Group: Forum Members
Posts: 2, Visits: 1

Hi,


I'm currently running an experiment that consists of a sequence of scripts in a batch file. Sometimes (but not every time) the batch crashes and the participant receives a Microsoft error message (where they ask you whether you want to send the error report).


It always happens at the same point: between "casus.exp" and "pldt1.exp", but as I mentioned not every time I run the experiment (so far 3 out of 15 times). I programmed & I'm running the experiment in Inquisit 3.0.4.0.


I've attached the whole experiment in a zipfile to this message, the batch is called 'Columbus'.


Thanks in advance for your help!


Kind regards,


Lieke




Attachments
experiment wk 41-2010.rar (296 views, 208.00 KB)
Tags
seandr
seandr
Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)Supreme Being (116K reputation)
Group: Administrators
Posts: 1.3K, Visits: 1K

Hi Lieke,


I'm running your script now to see if I can replicate and fix the crash. In the meantime, I'd recommend using Inquisit 3.0.5.0, as it has some bug fixes that might be related to this issue. If you do upgrade, please let me know if it appears to fix the issue.


Thanks,


Sean


Dave
Dave
Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)Supreme Being (830K reputation)
Group: Administrators
Posts: 10K, Visits: 58K

FYI, Sean, I've been able to replicate the crash. Here's the offset info as reported by Windows:


AppName: inquisit.exe     AppVer: 3.0.4.0     ModName: inquisit.exe
ModVer: 3.0.4.0     Offset: 001287ef


Haven't seen it crash under 3.0.5.0 yet, however occasionally the listed scripts appear to be run twice in a row under 3.0.5.0.


Cheers,


~Dave


Lieke
Lieke
Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)Respected Member (447 reputation)
Group: Forum Members
Posts: 2, Visits: 1

Hi,


When I tried a different version it didn't crash but started running in a loop, as Dave metioned (each experiment was repeated 3 times!). So to solve my problem I just made separate batches in stead of one, for assigning participants to the different conditions. This worked perfect. Apparently, the problem arose from using the 'subjects' attribute in the batch.


Thanks anyway for your quick responses!


Cheers,


Lieke


Tags
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search