removing 'next' option from a surveypage


removing 'next' option from a surveypage

Author
Message
jamieward
jamieward
Partner Member
Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)Partner Member (552 reputation)

Group: Forum Members
Posts: 8, Visits: 30
I want to remove the 'next' button from a survey page and just want to display the screen for a controlled amount of time (I basically want them to see an image for 5 seconds and then answer questions about it).

I can figure out how to display for 5 seconds but not how to remove the 'next'...

<surveypage p1>
/ questions = [1=patterns]
/ showbackbutton = false
/timeout = 5000
</surveypage>



Dave
Dave
Supreme Being
Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)

Group: Administrators
Posts: 9.2K, Visits: 39K
You cannot strictly "remove" the button. What you can do is move it off-screen via the /nextbuttonposition attribute:

<surveypage p1>
/ questions = [1=patterns]
/ showbackbutton = false
/timeout = 5000
/ nextbuttonposition = (-10%, -10%)
</surveypage>
ArifahAd
ArifahAd
Associate Member
Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)

Group: Forum Members
Posts: 12, Visits: 37
Dave - Tuesday, October 27, 2015
You cannot strictly "remove" the button. What you can do is move it off-screen via the /nextbuttonposition attribute:

<surveypage p1>
/ questions = [1=patterns]
/ showbackbutton = false
/timeout = 5000
/ nextbuttonposition = (-10%, -10%)
</surveypage>

This is what I need to do to, but how do you put it back again once the required questions have been answered?

Dave
Dave
Supreme Being
Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)

Group: Administrators
Posts: 9.2K, Visits: 39K
ArifahAd - Thursday, July 19, 2018

This is what I need to do to, but how do you put it back again once the required questions have been answered?

That is not possible. Nota bene: If you have set a question's /required attribute to true, the page will not move on before the question has been answered, not even when the "next" button is clicked.

ArifahAd
ArifahAd
Associate Member
Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)Associate Member (148 reputation)

Group: Forum Members
Posts: 12, Visits: 37
Dave - Thursday, July 19, 2018
ArifahAd - Thursday, July 19, 2018

This is what I need to do to, but how do you put it back again once the required questions have been answered?

That is not possible. Nota bene: If you have set a question's /required attribute to true, the page will not move on before the question has been answered, not even when the "next" button is clicked.

Yes that is what is happening now, but I have a stimulus image about which the users have to answer three questions all required - if any question is not answered when they click the page doesn't move on but the image disappears.

Dave
Dave
Supreme Being
Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)Supreme Being (516K reputation)

Group: Administrators
Posts: 9.2K, Visits: 39K
ArifahAd - Sunday, July 22, 2018
Dave - Thursday, July 19, 2018
ArifahAd - Thursday, July 19, 2018

This is what I need to do to, but how do you put it back again once the required questions have been answered?

That is not possible. Nota bene: If you have set a question's /required attribute to true, the page will not move on before the question has been answered, not even when the "next" button is clicked.

Yes that is what is happening now, but I have a stimulus image about which the users have to answer three questions all required - if any question is not answered when they click the page doesn't move on but the image disappears.

For future reference, answered here: https://www.millisecond.com/forums/FindPost25304.aspx

GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search