Trouble linking up with Qualtrics Panels


Trouble linking up with Qualtrics Panels

Author
Message
Morty
Morty
Expert
Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)

Group: Forum Members
Posts: 6, Visits: 54
Hi,
A few months ago, I followed the instructions in the documentation for linking Inquisit up with Qualtrics, and things were working fine for me. In the Qualtrics survey, I generated a random number for the URL Query Parameter (it was called "IATCode"), and was able to collect and sync data easily from the first half of the Qualtrics survey, the IAT task in the middle, and the final part of the survey, which bounces participants back to Qualtrics. 

Last month I decided to hand the survey over to Qualtrics Panels for help recruiting participants, which means i'm not designing the code myself, but am hoping you may have some helpful advice given the snag we've run into. Qualtrics Panels assigns four unique ID codes to each of their participants, several of which are alphanumeric, and they tell me they're not seeing those codes come back in the redirect from Inquisit back to Qualtrics. Are there any changes in this operation that would be necessary now that there are four URL Query Parameters rather than one, and now that some of them are alphanumeric rather than strictly numeric? 

Thanks a lot for all of your help.
Dave
Dave
Supreme Being
Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K
No, the alphanumeric nature is not a problem for Inquisit Web in principle -- it can handle those just fine, and -- in terms of passing them between Qualtrics and Inquisit Web -- it works just as with any other (numerical) query parameter. You need to, however, ensure that your *script* does not expect numerical subject ids for condition assignment, i.e., the /groupassignment attributes must be set to e.g. 'groupnumber' and you must ensure that a numerical group id is provided (either via another query parameter sent by Qualtrics or via the Inquisit Web launch page settings).

> they tell me they're not seeing those codes come back in the redirect from Inquisit back to Qualtrics

Overall, it sounds like something regarding the redirection between the two platforms is not working / not set up correctly in your case (I'm not sure on which side -- Qualtrics or Inquisit). I'd recommend you double-check the settings for your Inquisit Web experiment and your script and also make sure it uses the latest Inquisit Web version (4.0.9.0).

The general rule is that *all query parameters* that enter the launch page (i.e., those sent from Qualtrics) are automatically preserved and appended to the URL Inquisit is set to redirect to (e.g. another Qualtrics survey) when the Inquisit Web experiment finishes. They only exception would be when you explicitly override the redirection URL in your script by setting the defaults.finishpage property -- that would lead to all query parameters being discarded.

Hope this helps.

Morty
Morty
Expert
Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)

Group: Forum Members
Posts: 6, Visits: 54
Thanks for the reply, Dave. Just two more questions:
1) How should I be writing multiple variables into the script if I have more than one URL Query Parameters set up? I'd like to have four separate variables in place for each unique subject. Should they be separated by commas? 
2) If I'm not separating subjects into groups (i.e., all subjects get "the same" randomized sequence of stimuli in the IAT), then is it true that I don't need to set a group id? That this would just be set to "random without replacement"?

And, on another note, where can I find a link for upgrading from Inquisit Web 4.0.8.0 to 4.0.9.0?

Thanks again for all the speedy help,
Morty
Dave
Dave
Supreme Being
Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K
> 1) How should I be writing multiple variables into the script if I have more than one URL Query Parameters set up? I'd like to have four
> separate variables in place for each unique subject. Should they be separated by commas?

An Inquisit *script* can at most take in *two* query parameters -- one to use as subject id and another one to use as group id. Also, reading out those query parameters is not something that would be set up in your *script*, it would be set up via your web experiment's settings / the launch page configuration. The launch page itself, however, can take in *more* than two query parameters and it will preserve them all when redirecting to some other site at the end of the experiment (unless you explicitly override the redirection configured in your web experiment's settings by setting the defaults.finishpage property in your script; that would lead to all query parameters being discarded).

> 2) If I'm not separating subjects into groups (i.e., all subjects get "the same" randomized sequence of stimuli in the IAT), then is it true
> that I don't need to set a group id? That this would just be set to "random without replacement"?

If your experiment does not contain any between-subjects conditions (multiple <expt> elements or /group attributes defined in <variables>Wink, then you don't need to provide a numerical group id. You can set it to what you want (such as the default "random without replacement" option) -- if the script doesn't need / use it, its value will not affect the functioning of the script or otherwise matter in any way.

> And, on another note, where can I find a link for upgrading from Inquisit Web 4.0.8.0 to 4.0.9.0?

No link is needed. When you register a new web experiment, 4.0.9.0 will be available and selected automatically. If you already have an experiment registered under a previous version (e.g. 4.0.8.0), you would have to unregister and then re-register said script to have it use 4.0.9.0.

Hope this helps.

GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search