Valid response error


Author
Message
ClinicalRes
ClinicalRes
Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)
Group: Forum Members
Posts: 9, Visits: 28
Hello,
I'm new to inquisit and trying to run a simple trial that represents two picture stimuli and prompts for selection, the script is as below:

<item foodpics>
/1 = "0001.jpg"
/2 = "0002.jpg"
</item>

<item foodcaptions>
/1 = "Pick your preferred type of food by clicking on one of the pictures:"
</item>

<text foodcaption>
/ items = foodcaptions
/ select = 1
/ position = (50%, 20%)
</text>

<picture food1>
/ items = foodpics
/ select = 1
/ position = (30%, 50%)
</picture>

<picture food2>
/ items = foodpics
/ select = 2
/ position = (70%, 50%)
</picture>

<trial foodchoice>
/ stimulusframes = [1=foodcaption, food1, food2]
/ validresponse = (food1, food2)
/ ontrialend = [if(trial.foodchoice.response=="food1")values.foodchoice="0001.jpg"]
/ ontrialend = [if(trial.foodchoice.response=="food2")values.foodchoice="0002.jpg"]
</trial>

I'm getting the errors: valid response food1 is not a valid setting and valid response food2 is not a valid setting. 
Any idea why this error is happening? 


Dave
Dave
Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)Supreme Being (782K reputation)
Group: Administrators
Posts: 10K, Visits: 51K
> I'm getting the errors: valid response food1 is not a valid setting and valid response food2 is not a valid setting. 
> Any idea why this error is happening?

/inputdevice needs to be set to mouse in either the <trial> or the <defaults> element for this to work.

If /inputdevice is not specified, Inquisit assumes keyboard as the default. 'food1' and 'food2' are not valid settings for keyboard input.

<trial foodchoice>
/ inputdevice = mouse
/ stimulusframes = [1=foodcaption, food1, food2]
/ validresponse = (food1, food2)
/ ontrialend = [if(trial.foodchoice.response=="food1")values.foodchoice="0001.jpg"]
/ ontrialend = [if(trial.foodchoice.response=="food2")values.foodchoice="0002.jpg"]
</trial>
ClinicalRes
ClinicalRes
Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)Partner Member (846 reputation)
Group: Forum Members
Posts: 9, Visits: 28
Yes, adding the input device removed the error. Thank you so much!
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search