BART crashing - Sound problem on Mac?


BART crashing - Sound problem on Mac?

Author
Message
aliucsd
aliucsd
Expert
Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)

Group: Awaiting Activation
Posts: 10, Visits: 19
Hi,

I am running the most recent version of the BART (regular version, not auto) on Inquisit 4 (downloaded today, 6/20/2016), on a Mac running OSX 10.9.4 and getting the following error. Any help would be great, thanks!

Checking system capabilities...

Timer resolution: 0.0000010000000000000 milliseconds

Display: 0: Color LCD

Color resolution: 32 bits per pixel

Display mode: 1440 x 900

Refresh Rate: 60 Hz

Videosync support: WaitForVerticalBlank mode.

Building Experiment...

Extracting elements from /Users/neurocoged/Downloads/BART/BART.iqx...

Parsing elements...

<picture collectbutton>

<trial choice>

<picture pumpbutton>

<trial instructions>

<data>

<text totalearnings>

<values>

<picture balloon>

<defaults>

<trial collect>

<sound popsound>

<block summary>

<picture collectbuttonselected>

<expt BART>

<picture poppedballoon>

<list pumpresult>

<picture pumpbuttonselected>

<text ballooncount>

<text potentialearnings>

<expressions>

<trial pop>

<block BART>

<item instructions>

<shape blank>

<sound collectsound>

<text pumpcount>

<sound inflatesound>

<text instructions>

<trial init>

<summarydata>

Results...

Sound Player Error -10879: Audio Unit: Invalid Property. Line 455, File /Users/seandr/inquisit/IQRuntime/mac/SoundPlayer.mm

Unexpected exception: -[NSRunWindow contentLayoutRect]: unrecognized selector sent to instance 0x7f9b9293cfe0

Dave
Dave
Supreme Being
Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K
The error suggest that your Mac for some reason has a problem with its audio interface or some of the files involved.
Questions:
- Does audio otherwise work fine on this system?
- What is the system's audio setup (e.g. using only internal speakers, using external audio devices attached via HDMI or the like)? In other words: Is there anything special or unusual about the configuration?
- Do the files play back fine in iTunes?
- Are there any other applications running concurrently using the soundcard(s) in some extensive capacity?

Thanks!

aliucsd
aliucsd
Expert
Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)

Group: Awaiting Activation
Posts: 10, Visits: 19
Thanks! 

Questions:
- Does audio otherwise work fine on this system?
It appears to, yes.

- What is the system's audio setup (e.g. using only internal speakers, using external audio devices attached via HDMI or the like)? In other words: Is there anything special or unusual about the configuration?
Internal speakers only.

- Do the files play back fine in iTunes?
They play back in iTunes with no problems.

- Are there any other applications running concurrently using the soundcard(s) in some extensive capacity?
I shut down all other programs and am now getting the following error -- is it looking for differently-named files?

Checking system capabilities... Timer resolution: 0.0000010000000000000 milliseconds Display: 0: Color LCD Color resolution: 32 bits per pixel Display mode: 1440 x 900 Refresh Rate: 60 Hz Videosync support: WaitForVerticalBlank mode. Building Experiment... Extracting elements from /Users/neurocoged/Desktop/BART/BART/BART.iqx... Parsing elements... <picture collectbutton> <trial choice> ERROR: Expression 'sound.inflatesound' is invalid. Expression contains an unknown element or property name.<picture pumpbutton> <trial instructions> <data> <text totalearnings> <values> <picture balloon> <defaults> <trial collect> ERROR /stimulustimes: Could not locate element 'collectsound'.<text continuebutton> <block summary> <picture collectbuttonselected> <expt BART> <picture poppedballoon> <list pumpresult> <picture pumpbuttonselected> <text ballooncount> <text potentialearnings> <expressions> <trial pop> ERROR /stimulustimes: Could not locate element 'popsound'.<block BART> <item instructions> <shape blank> <text pumpcount> <text instructions> <trial init> <summarydata> <parameters> Results...

Dave
Dave
Supreme Being
Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)Supreme Being (678K reputation)

Group: Administrators
Posts: 9.8K, Visits: 46K
The parser output you included indicates a problem with your script. Specifically, the parser is unable to locate several <sound> elements:

<sound inflatesound>:
<trial choice> ERROR: Expression 'sound.inflatesound' is invalid. Expression contains an unknown element or property name

and

<sound popsound>:
<trial pop> ERROR /stimulustimes: Could not locate element 'popsound'.

As far as I can determine all of those are defined properly in the script as it is available in the library. I.e., this would suggest the errors are due to (perhaps inadvertent) modifications you made to the script.

aliucsd
aliucsd
Expert
Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)Expert (1.2K reputation)

Group: Awaiting Activation
Posts: 10, Visits: 19
Strange! I didn't make any modifications to the script at all. I will try re-installing and see if that works.
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....






Millisecond Forums


Search