Data file makes new directory


Author
Message
BasE
BasE
New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)
Group: Forum Members
Posts: 12, Visits: 47
Hello all,

Currently I have a small issue with the saving of my data. Currently my code states that it needs to save a file to specific directory, like this:

<data>
/ columns=[subject, blockcode, trialcode, trialnum, latency, response, stimulusitem, stimulusnumber]
/ file = "C:\Users\BasE\Desktop\CBM-I\Data"
/ encrypt= false
</data>
This is an existing directory on my pc. However, when it saves the data it makes a new directory using the same names instead of using the existing directory. I feel like I am missing a line of code here, can someone point out to me what is going wrong here?

Many thanks in advance!

Dave
Dave
Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)
Group: Administrators
Posts: 11K, Visits: 73K
BasE - 9/7/2021
Hello all,

Currently I have a small issue with the saving of my data. Currently my code states that it needs to save a file to specific directory, like this:

<data>
/ columns=[subject, blockcode, trialcode, trialnum, latency, response, stimulusitem, stimulusnumber]
/ file = "C:\Users\BasE\Desktop\CBM-I\Data"
/ encrypt= false
</data>
This is an existing directory on my pc. However, when it saves the data it makes a new directory using the same names instead of using the existing directory. I feel like I am missing a line of code here, can someone point out to me what is going wrong here?

Many thanks in advance!

Unable to reproduce this under Inquisit 6.5.0 or 6.4.2. The data files end up in the existing, specified directory, no new directory is created. Note:
If you want a single data file, instead of a separate file per run, specifiy /separatefiles = false in the <data> element.
BasE
BasE
New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)
Group: Forum Members
Posts: 12, Visits: 47
Dave - 9/7/2021
BasE - 9/7/2021
Hello all,

Currently I have a small issue with the saving of my data. Currently my code states that it needs to save a file to specific directory, like this:

<data>
/ columns=[subject, blockcode, trialcode, trialnum, latency, response, stimulusitem, stimulusnumber]
/ file = "C:\Users\BasE\Desktop\CBM-I\Data"
/ encrypt= false
</data>
This is an existing directory on my pc. However, when it saves the data it makes a new directory using the same names instead of using the existing directory. I feel like I am missing a line of code here, can someone point out to me what is going wrong here?

Many thanks in advance!

Unable to reproduce this under Inquisit 6.5.0 or 6.4.2. The data files end up in the existing, specified directory, no new directory is created. Note:
If you want a single data file, instead of a separate file per run, specifiy /separatefiles = false in the <data> element.

Coul it be something specific to my pc then? I included a screenshot where the newly created directory is shown ("Gebruikers" meaning "Users", deleted username for privacy reasons).


Attachments
Screenshotdirectory.png (6 views, 60.00 KB)
Screenshotdirectory2.png (7 views, 3.00 KB)
Dave
Dave
Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)Supreme Being (957K reputation)
Group: Administrators
Posts: 11K, Visits: 73K
BasE - 9/7/2021
Dave - 9/7/2021
BasE - 9/7/2021
Hello all,

Currently I have a small issue with the saving of my data. Currently my code states that it needs to save a file to specific directory, like this:

<data>
/ columns=[subject, blockcode, trialcode, trialnum, latency, response, stimulusitem, stimulusnumber]
/ file = "C:\Users\BasE\Desktop\CBM-I\Data"
/ encrypt= false
</data>
This is an existing directory on my pc. However, when it saves the data it makes a new directory using the same names instead of using the existing directory. I feel like I am missing a line of code here, can someone point out to me what is going wrong here?

Many thanks in advance!

Unable to reproduce this under Inquisit 6.5.0 or 6.4.2. The data files end up in the existing, specified directory, no new directory is created. Note:
If you want a single data file, instead of a separate file per run, specifiy /separatefiles = false in the <data> element.

Coul it be something specific to my pc then? I included a screenshot where the newly created directory is shown ("Gebruikers" meaning "Users", deleted username for privacy reasons).


Double-check your /file attribute in the <data> element. You almost certainly have a typo in there, e.g. a trailing space in "Gebruikers ".

BasE
BasE
New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)New Member (33 reputation)
Group: Forum Members
Posts: 12, Visits: 47
I found the issue! It appears that Inquisit gets confused when I specify my directory in Dutch, which I translated in the original post for an international audience. Copying the directory directly in to the <data> and switching the text to English worked in the end. Thanks for your help regardless, Dave
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search